Shaders not supported

Ok this is really weird for me. I 've been programming OGL (fixed functionality) for years now but I’ve never really thought about drivers for OGL as such.

Now I’m trying to run the brick example from the orange book and it tells me “OpenGL Shading Language extensions not available”

I’m running an NVidia 5900XT (says fully DirectX 9 compatable on the box) with the latest nvidia drivers.

What more do I need to do to enable OGL Shader extensions?

The answer is on this same page titled “Geforce FX Help”;f=11;t=000290

Have you tried the suggestions?
Have you tried leaked drivers?

Thanks, I downloaded the leaked 62.11 nvidia drivers and it worked.

I just don’t understand why my $300 video card can’t run a standard like OpenGL 1.5 when I install an official driver that claims “Directx 9 and OpenGl 1.5 support” (56.72)

What if one doesn’t like running “leaked” drivers etc.

It seems pretty piss-poor for Nvidia to say it runs 1.5 only to run an example from the Orange Bookand tell me it doesn’t run 1.5. And then to have to spend an hour chasing down and downloading “leaked” drivers to get the thing to work.

Thanks again V-man for the prompt reply that got me up and running

The OpenGL Shading Language extensions are NOT part of OpenGL 1.5.

I thought the orange book was indicating that the shader extensions are approved for inlcusion since 1.5?

Oh well live and learn

No, they will be included in OpenGL 2.0.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.