NVShaderPerf ASM output w. GLSL vertex shaders buggy?

I can’t get NVShaderPerf 81.95 to output assembly for glsl vertex shaders. :frowning:
Pixel shaders are working correctly with .glsl file extension but not with -type glsl_ps.

Is this a bug in nvshaderperf or I am doing something wrong? :confused:

Repro steps:

  1. create simple.glslvp with:
    void main()
    gl_Position = ftransform();

  2. in command prompt type:
    prompt> nvshaderperf.exe -type glsl_vs simple.glslvp

Running performance on file simple.glslvp

Yep, I have the same problem (just tried it, same version). Perhaps we’re just missing an elusive command switch.

I tried all sorts of permutations on the basic theme.

nvshaderperf.exe -type glsl{_vs|_ps} test.vsh

No error reports of any kind.

The *.fx stuff works fine.

@leghorn: Thanks for confirming the bug! :slight_smile:

I’ve found a “workaround” - NVEmulate Build: Feb 17, 2005 is working properly with Nvidia ForceWare 91.31 - so I’m able to dump VP assembly through that.

NVShaderPerf working would still be nicer, though. I’ll send a bug report to SDKFeedback@nvidia.com.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.