New ATI Drivers, GL_FOG slowdown

Just updated to the latest ATI drivers and I had GL_FOG left enabled in my code when I started drawing surfaces with shaders and experienced a massive slowdown (1 frame every 2 seconds). Spent a couple hours today trying to figure out why everything was going so slow on the new drivers, commented out glEnable(GL_FOG) and bingo, 200fps.

Now I shouldn’t have left fog enabled for surfaces using vertex shaders, so it was a bug in my code, but I would also consider it a bug in the driver code.

Posting this because I am sure something like this will happen to someone else, now you know where to look (your fixed function code).

See here .

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.