Linker error under Bc45

I installed the glut files and gl.h, opengl32.dll and everything that comes with them. Almost every site tells me to download their own opengl stuff, but there is always something missing (a file, a .lib, etc.). I already got a project that should run (according to the tutorial on the net). I added the glut32.lib node, but it won’t compile. I get the message:

Linking proj0001.exe:
IDE error :
BCW: unexpected termination during link [BCWS32 0000:0000]

What can be the problem?

I’ve been already working around with the damn glut stuff for a couple of weeks, but i got only the gl thing working under win32 (i have to make my own window handler, etc.).

Please, can someone help me? Someone who is good at Opengl(not just talking around!!) ?

BC uses a different library format than VC++. You’ll have to convert it. I think the utility BC++ has for that is called implib. I don’t use Borland, so I’m not sure. Do a search on the forum and you’ll find all the info you need on how to do this.

Isn’t BC4.5 a 16 bit compiler? Wont this mean it just wont work with OpenGL (which has 32 bit headders and libraries)??
Or am I just being silly.


BC4.5 can compile 32 bits applications and yes, you’ll have to use implib to create lib files compatible with Borland’s compilers.

I’ve already used the implib like this:

c:\win98\system> implib glut32.lib glut32.dll

but i got an access violation message. Paul Groves wrote that i should do this. It didn’t work. The funny thig is that programs that i wrote including gl.h and windows.h worked, but when i included (only included and didn’t used the functions) the glut.h everything crashed.

Is this because my implib is broken or is it glut that is wrong?

( My glut was downloaded from : )

Well, don’t forget not to leave glut.lib in win98\system. you have to replace the one you got when you downloaded glut with this new one and put it in the lib directory of your compiler.

By the way, if you get an access violation, I don’t think it has somehing to do with the format of your .lib so there may be another issue.

The problem is that you are using pretty old tools. You can try this:
impdef glut32.def glut32.glut32.dll
implib glut32.lib glut32.def

If impdef fails is a glut32.def in the sources from Nate Robins. Another alternative is to use coff2omf to convert the VC lib to Borland format. Borland compatible libraries can be downloaded from the net:
and at other places but they are for newer tools and may perhaps not work.

If nothing else works download t a free compiler like Borland’s or buy a new compiler!

Ok, guys! Thanks for your help!
I tried to download stuff and ask more persons, but it looks like that my bc45 is a trash or something. Now i got the bc55 and glut runs perfectly with it.
I won’t use the bc45 anymore!