How to use hw rendering on a Voodoo2 with OpenGL??

Don’t tell me to buy a new card…
I’m not able to accelerate my ogl apps (and NeHe’s demos too…): I tried glsetup, or downloading the latest drivers from 3dfx.
Both contain something like:
OpenGL® Driver Version: ICD
this isn’t the minigl driver, I suppose, this seems to be opengl, but nothing happens.
Do I need to obtain a specific opengl32.dll?

If somebody is coding with a v2, please give me some help…

I think the v2 has lots of limitations : fullscreen, color depth (16 ?), no stencil buffer, limited screen size (800x600 ?) and so on. You should be able to get OpenGL hw accelerated but with the “wrong” settings do you get software.

Buy a new card.

Sorry. Couldn’t resist!

hey i dont know much openGL but i do know this…u need a new card. hehe. seriously though you got yourself and old one. well im not goona pretend like i know anything i odnt but i read somewhere that the old voodoo cards had a dual processer design and are incompatable with some OGL apps. but i saw that there was some way of fixing it with some code. oh well tahts about all the knowledge i have about OGL so i gonna shutup. hehe

P.S. get a new card

 P.P.S. Hehe

Are you putting the opengl32.dll in the same directory as your program file? Works for me on my wonderfully hi-tech Orchid Righteous 3D (Voodoo I).

I found this in another forum:
"this is how i do it:
go to WINDOWS\SYSTEM and copy 3DFX32V2.DLL to the directory where your executable is, then rename it to opengl32.dll,

remember your voodoo2 only works in exclusive mode so you’ll need to run your app fullscreen "

Ok… I tried it but it didn’t work.
I saw a file called 3dfxvgl.dll - oh, it contains ‘gl’ !! - and I tried with that…
It seems to work!!!
eh, no.
Another problem.
glide3x.dll (instruction not valid)
This pseudo opengl uses glide, that’s ok, but glide3 doesn’t works!
Now I’ll look for a good glide3x, thanks to all!

Ps: I found something similar, a mesa implementation, same errors with glide.

Glide isn’t a must, I think.

Visit this site:

The Author desribes a method, to reference the dll for your V2.

I’ve tested it. Works perfectly.


Try this one:

Thank to all!
I’m now officially hw!

OpenGL version: 1.1.0
Renderer: 3Dfx/Voodoo2/2 TMUs/4 MB/stand-alone (Jan 17 2000)
Vendor: 3Dfx Interactive Inc.
Extensions: GL_ARB_multitexture GL_EXT_abgr GL_EXT_bgra GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_packed_pixels GL_EXT_paletted_texture GL_EXT_point_parameters GL_EXT_shared_texture_palette GL_EXT_stencil_wrap GL_EXT_texture_env_add GL_EXT_vertex_array GL_SGIS_texture_edge_clamp GL_SGIS_multitexture WGL_3DFX_gamma_control WGL_EXT_swap_control

Thanks to all of you again!


How did you got infos about the driver?

Sorry,i’m a real beginner =)