GLW_StartOpenGL() - could not load OpenGL subsystem

Hi ive got a sis 6326agp and a gullimot maxi gamer voodoo1 4mb and ive never had any problems with games really until now. Ive just installed the latest star trek voyager game and when i try and run it i get an error message(scaled down a bit)
…GLW_ChoosePFD failed
…GLW_ChoosePFD( 16, 16, 0 )
…23 PFDs found
…GLW_ChoosePFD failed
…failed to find an appropriate PIXELFORMAT
…restoring display settings
…WARNING: could not set the given mode (3)
…shutting down QGL
…unloading OpenGL DLL
…assuming ‘3dfxvgl’ is a standalone driver
…initializing QGL
…WARNING: missing Glide installation, assuming no 3Dfx available
…shutting down QGL
----- CL_Shutdown -----
RE_Shutdown( 1 )

GLW_StartOpenGL() - could not load OpenGL subsystem
Now ive installed opengl setup and think ive got the right voodoo drivers as i can run driver and need4speed5 with no problem and can select the 3dfx glide2x and get the 3dfx logo spinning.
Please can you help me as im goin mad and cant wait to play it.
Thanx in advance,
LuCiFeR… http://surfdude.8k.com

I HAVE THE EXACT SAME FRICKEN PROBLEM…

I KNOW HOW YOU MUST FEEL.

THE ONLY ADVICE I CAN SUGGEST IS TO INSTALL WIN98 AND PLAY IT FROM THERE AS IT WORKED PERFECTLY WITH ME THAT WAY BEFORE I GOT WIN2K.

NIEL

ps. STEliteForce is an AMAZING game!!!

The same happened to me but with the Quake 3 Arena Demo. Can’t find a solution for this problem.

yea my q3 doesn’t work either, i just installed w2k the other night for the first time and updated EVERYTHING!! the newest service packs, my motherboard bios, my video card drivers (diamond stealth 3 agp extreme), i’ve been on the phone w/ diamond tech support and they have been telling me dif. thing to do, but nothing is working… if someone finds out what to do could they please e-mail me jsly@pioneeris.net any help would be great!!!

When I istalled Win2K, no OpenGL would work. A friend suggested I install the OPenGL libraries…even tho hey are supposedly included with win2k I said what the heck…and it WORKED…I was playing Q2, Q3, and Unreal Tourney in Open GL perfectly. Sadly, now the OPen GL has stopped working, and reinstalling video drivers and the GL libraries is no help. Any ideas?

I don’t think this really applies to what is being discussed but I think one of you could help me. I have downloaded Quake3 demo onto a cd-rom transferred it to another computer and now I am trying to get opengl setup on the computer I transferred it to, but that computer only connects at 28000 baud so it would take forever to download the proper opengl driver for it. Question–if I know what 3d card I have (ati 3d rage pro) can I go to a web site and load that specific opengl driver onto a cd rom and then install that onto another computer (the only one I have access to that can run Quake3)
Please help–I am dying to play Quake3demo.
please email at pet20000@yahoo.com
thanks

and again quake3 did not work.there was something about:GLW Start OpenGL()- could
not loud OpenGL Subsystem. If anyone can help
me please do, cause I do not know what to
do anymore.

I solved the problem with the Quake III engine where it says “could not load OpenGL subsystem”.

I had the problem with the demo of Heavy Metal F.A.K.K. 2 running under win95 and using the 3D Prophet (GeForce 1).

First of all I installed the newest drivers from NVidia (detonator 3, version 6.31). This helped a little but did not yet start the game.
After that I followed the instructions in one of the posts down here:

Open the win.ini and search for the string “DVA” then set an smikolon in front of DVA and save the win.ini.

After that FAKK 2 started perfectly. I haven´t yet tried it with Star Trek Elite Force Demo or the Quake III Demo but I think it should work also with both of them.

Hope anyone else will be as successful as I was.

yes i have the same problem with my pine sis6326, i’ve installed the lastest drivers from pine and tried the drivers from sis, but none of them let me play open gl games! how do i get the open gl libraries then? or how do i get this to work?

yes i have the same problem with my pine sis6326, i’ve installed the lastest drivers from pine and tried the drivers from sis, but none of them let me play open gl games! how do i get the open gl libraries then? or how do i get this to work?

yes i have the same problem with my pine sis6326, i’ve installed the lastest drivers from pine and tried the drivers from sis, but none of them let me play open gl games! how do i get the open gl libraries then? or how do i get this to work?

I have a sis 6326 pci card + 8meg - i searched high and low for a Opengl driver for it to run Quake 3 and here it is http://www.matsonic.com.tw/sis6326/win98/326win98.exe
dont forget you still need the opengl dll’s in your windows/system drawer - you can get these from the opengl site

Initializing OpenGL driver
…getting DC: succeeded
…GLW_ChoosePFD( 16, 16, 0 )
…35 PFDs found
…GLW_ChoosePFD failed
…GLW_ChoosePFD( 16, 16, 0 )
…35 PFDs found
…GLW_ChoosePFD failed
…failed to find an appropriate PIXELFORMAT
…restoring display settings
…WARNING: could not set the given mode (3)
…shutting down QGL
…unloading OpenGL DLL
…assuming ‘3dfxvgl’ is a standalone driver
…initializing QGL
…WARNING: missing Glide installation, assuming no 3Dfx available
…shutting down QGL
----- CL_Shutdown -----
RE_Shutdown( 1 )

GLW_StartOpenGL() - could not load OpenGL subsystem

This is the exact error message that I got trying to open QIII on a win 2000 PIII 650 machine with an ATI Rage Fury Pro Card. I’m not sure what the win.ini file thing does as I cant find the specific line in it to change.
I have the very latest drivers that ATI offers, (believe it or not they already come on the win 2000 cd) so I dont know what else to try? Luckily my other pc has a geforce so I dont have probs like these but I would like to play QIII on win 2K …any ideas?

Q3 1.17 win-x86 Apr 27 2000
----- FS_Startup -----
Current search path:
E:\Programme\Quake III Arena\baseq3\pak3.pk3 (4 files)
E:\Programme\Quake III Arena\baseq3\pak2.pk3 (148 files)
E:\Programme\Quake III Arena\baseq3\pak1.pk3 (26 files)
E:\Programme\Quake III Arena\baseq3\pak0.pk3 (3539 files)
E:\Programme\Quake III Arena/baseq3


execing default.cfg
execing q3config.cfg
couldn’t exec autoexec.cfg
…detecting CPU, found Intel Pentium III

------- Input Initialization -------
Initializing DirectInput…
Couldn’t set DI coop level
Falling back to Win32 mouse support…
Joystick is not active.

----- Client Initialization -----
----- Initializing Renderer ----

----- Client Initialization Complete -----
— Common Initialization Complete —
Winsock Initialized
Opening IP socket: localhost:27960
Hostname: psycho-500
IP: 10.0.0.140
IP: 213.33.30.124
Working directory: E:\Programme\Quake III Arena
----- R_Init -----
Initializing OpenGL subsystem
…initializing QGL
…calling LoadLibrary( ‘E:\WINNT\System32\opengl32.dll’ ): succeeded
…setting mode 3: 640 480 FS
…using desktop display depth of 32
…calling CDS: ok
…registered window class
…created window@0,0 (640x480)
Initializing OpenGL driver
…getting DC: succeeded
…GLW_ChoosePFD( 32, 24, 8 )
…35 PFDs found
…GLW_ChoosePFD failed
…GLW_ChoosePFD( 32, 24, 0 )
…35 PFDs found
…GLW_ChoosePFD failed
…failed to find an appropriate PIXELFORMAT
…restoring display settings
…WARNING: could not set the given mode (3)
…setting mode 3: 640 480 FS
…using colorsbits of 16
…calling CDS: ok
…created window@0,0 (640x480)
Initializing OpenGL driver
…getting DC: succeeded
…GLW_ChoosePFD( 16, 16, 0 )
…35 PFDs found
…GLW_ChoosePFD failed
…GLW_ChoosePFD( 16, 16, 0 )
…35 PFDs found
…GLW_ChoosePFD failed
…failed to find an appropriate PIXELFORMAT
…restoring display settings
…WARNING: could not set the given mode (3)
…shutting down QGL
…unloading OpenGL DLL
…assuming ‘3dfxvgl’ is a standalone driver
…initializing QGL
…WARNING: missing Glide installation, assuming no 3Dfx available
…shutting down QGL
----- CL_Shutdown -----
RE_Shutdown( 1 )

GLW_StartOpenGL() - could not load OpenGL subsystem

i have the same problem as you guys…please help me, i don’t know what i have to do

i have a Ati rage 128

I have the exact same problem as well. Game is American McGee’s Alice. Video card is Creative Labs Annililator 2 (GeForce2)

I’m not sure but I think the problem is that the driver doesn’t support full screen OpenGL.

Try this program at http://nehe.gamedev.net/projects/water/water.htm

It displays an option to run in full screen mode. I get an error message when I try. No problem running in window mode however.

For the NeHe demo, change your desktop color depth to 16 bit.

I don’t know if that will fix the game stuff, though.

j

Thanks j,

That was exactly the problem (had color set to 32 bit). I would never have considering changing the color depth.

Fixed the Alice game too.

I also have the problem: Could not loud Open GL. I have a Savage 4 card, and I have no idea what to do, maybe somebdoy could help me??
Thanks in advance.
Chrisu_77@gmx.at

Same problem, GeForce 2 MX…
www.glsetup.com is unavaible!