Debugging/performance window on HoloLens2 application

Hi everyone, I am new here. I hope that one of you might know the answer to this very annoying problem, which I so far did not have success finding a solution for.
I am developing a HoloLens application to do a study on for my master thesis.
whenever I build the application and launch it I am faced with this annoying debugging window and I have no clue on how to disable it. In unity when I go into play the window is not showing, it only appears when I launch the application. so far I have found that this debugging window only appears in the application when I enable the OpenXR in unity here:

The debugging window looks like this:

I had to reverse the URL as I am not allowed to upload links

So basically (to facilitate scanning and web searches), you’re asking how to get rid of the WHITE on RED pop-up performance stats dialog that contains the following, right?:

App Cpu/Gpu: .../... ms ... Hz
Pre Cpu/Gpu: .../... ms
Post Cpu/Gpu: .../... ms
Pose Age: ... ms
Compositor Type: ... 
Cpu/Gpu Status: .../...
Warning/Error: ...

That’s new user spam avoidance. Keep using the forums and you’ll be past this limitation in no time.
I fixed the links for you. In the interim, reversing all chars works, but you can just put a space up in the :// substring so the forums don’t auto-format it as a URL link. Easier to fix later :slight_smile:

yes you are correct, I want to disable the performance stats dialog. The log doesn’t show in Unity play mode but when I build the project and launch the application on the HoloLens it appears right in front of your face all the time ruining the user experience.
thank you for this quick response :slight_smile:

also thanks for the advice :smiley:

This is usually controlled by the OpenXR Tools for Windows Mixed Reality app:

1 Like

I’m from OpenXR team for HL2 and I can confirm what @Jabbah said is correct.

You can find this “OpenXR tools” app on your HL2 in your start menu, and uncheck the “Display frame timing overlay” or click the “Reset all settings” to avoid debug settings on your HL2 experience.

1 Like

To both of you Jabbah and Yl_msft.
Thank you so much for taking time reading my posts, this was exactly the answer I was looking for! finally I can get rid of the debugging window.

A follow up question:
When I build the same project but an updated version and I get that onto the HoloLens2 how do I prevent it from overriding the already existing application on the HoloLens2 I tried incrementing the version in unity player settings and also changed the name of the product. But it seems to override the already existing application.

Once again thank you so much! This has been bugging me a lot…

As long as the application has the same package identity name, the application will be considered as same one and when you upload the new package it will override older one.

You will need to change the <Package …> <Identity Name=“ChangeToNewName” …> in the Package.appxmanifest file (in the generated VisualStudio project) to allow your app installed side by side with another one. Note they will not share the same app states, such as permissions for eye tracking etc.

Also worth to know that you can change this identity in Unity’s setting, but it doesn’t override the manifest when you do incremental build in Unity. So unless you do a clean build (by deleting the VisualStudio project folder), changing identity in unity’s setting won’t take effect. It was designed this way to avoid unity accidentally stamp on your project changes. If you do like to change the package identity in unity project, make sure you do a clean build.

1 Like

Okay, so I have a feeling that this Package.appxmanifest file is specific to the building process using Visual Studio. I found building the project using the “Build Window” included in the MRTK package (Tools) within unity a bit quicker and more convenient in general. Is it possible to changed the “Identity Name” when the package has already been build or will I have to use Visual Studio this is the AppPackage folder that I have created of my project:
“I use the device portal to install the application to the HL2”

These are two different builds of two different unity projects, but for some reason they share the same PackageFullName: as can be seen in the error message. to the right of the picture information of the already installed app interfering with the installation process is displayed (different unity project build) “Template3D_1.0.1.0_arm64__pzq3xp76mxafg”

You can set this new identity in unity settings image

But unity build system will deliberately avoid stamp on existing generated code for VisualStudio in incremental build, so your change in unity setting above won’t take effect. You will need to do a clean build, meaning deleting the intermediate VS files generated by the build tool you were using. I’m not familiar with MRTK build window, might need you explore a bit.

I’m not sure how to do this after the app is already packaged into an appx package like above.

After you did the clean build, or manually modify the file in VisualStudio, you will find your app show up twice in the DevicePortal like following:
image

1 Like

aaah, thanks I will try that out

I couldn’t help but notice that you are one of the contributors of to the project
link:

Maybe you can answer another question I added to the community regarding XR and spatial alignment of objects:
link:

Thank you for your detailed descriptions. Very helpful