Built-in Uniforms

Suddenly my fragment shader refuses to acknowledge any state changes in OpenGL.

gl_LightPosition[] does nothing when i move the light around.

gl_FrontMaterial.diffuse makes no difference.

I don’t need to have the shader active when making state changes, right?

I’m also pretty sure the shader and the state changes are in the same context.

I’m a little confused, any tips?


I had the same problem, it was solved by getting the 66.81 nVidia drivers. But the shader never worked for me, it did not “suddenly stop working”, so this might not help you…

Hey Nico,

There doesn’t seem to be a 66.81 driver anywhere on the nVidia website. The 66.93 one I found didn’t solve it.

The registered developer section didn’t have that driver version either.

I know this shader worked at one point or another a few months back, unfortunately I can’t remember what driver version I was using back then.

I suppose I’m going to try some of the recent drivers from the past and see if i can get it working again…if you happen to have an installer for that driver version do you think you could pass it over to me?



um…NVM. found the tread you started a little while back. :slight_smile:

thanks anyway, cheers.

edit: thanks that did it.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.