xrCreateSession slow to return with Meta Quest Link runtime

I’m experiencing a long delay (around 30 seconds) with calling xrCreatSession when using the Oculus Rift S with the Meta Quest Link runtime (version on Windows 10. The slowdown appears to be caused by enabling the XR_FB_face_tracking and XR_FB_eye_tracking_social extensions, where each extension appears to add a roughly 15 second delay. I understand the Rift S does not support either of these features, but the runtime reports that they are supported when calling xrEnumerateInstanceExtensionProperties. xrCreateSession eventually returns successfully and the eye/face tracking extension functions correctly fail when attempting to initialize them.

I can prevent the slowdown by either not enabling these extensions when using the Rift S or by disabling the eye/face tracking features from the Beta tab of the Meta Quest Link app. However, I’d prefer to not have to attempt to detect which device is being used in order to have my application run properly.

Is this a known issue with the Meta runtime? Apologies if this is not the appropriate forum to report the issue.

Wait, so are you using a Quest (via Quest Link), or a Rift S? (Or did they rename the Oculus PC runtime app since the last time I tried it?)

This does sound weird, though.

I can confirm this problem is happening with a Quest 1 (via Oculus Link), and only on the OpenXR runtime of Oculus. It works fine with the OpenXR runtime of SteamVR.

I’m using Blender (with the default VR plugin), and this problem started last week after a Quest 1 software update (when the “white” meta logo started appearing after connecting via Oculus Link, instead of the “blue” meta logo).

Again, it works just fine with the OpenXR runtime of SteamVR, I tried it just now. That’s what I’m using right now as a workaround (instead of Oculus’s OpenXR runtime).

So it might be something specific to a recent change in Oculus’s OpenXR runtime, and probably specific to older VR headsets.

I’m also keen to find a solution for this, just reporting what I’ve found so far.

Ah, just saw the related post. Looks like it’s a known and tracked issue with Oculus.

I’m not allowed to post links yet, so please remove the space after “atmeta” before “.com”:
communityforums.atmeta .com/t5/OpenXR-Development/OpenXR-Hanging-after-v62-update/td-p/1149376