whte thingy

I have written a flat shading app… I want to anti-alias the whole view, white streak appears between the lines and the polygon… help

could you post a screen shot?

From the description it sounds like the usual polygon_smooth with depth buffering issue.
The edges between polygons are blocked by the depth buffer value of the first polgon which touches them, they antialias with the background and the next polygon sharing that edge cannot add to the final color anymore.
The color of the stitches is dependent on the drawing order, means the background color at the time the first polygon touches it.

Read the RedBook (OpenGL programming guide) on polygon antialising and you’ll find that you need to disable depth buffering, enable the special blending mode which saturates alpha, and sort you polygons from front to back, because the saturation should not block the frontmost polygons.

This is so yesterday. :wink:
Search the forum for multisampling.
You can programmatically enable a full scene antialiased pixelformats if your implementation supports it. You don’t need to change your main rendering code like for polygon_smooth method then.


>>C:\Documents and Settings\matthewg\Desktop\help.jpg

Well done ! Now we all know that your screenshot lies on your windows desktop … :smiley:

yes i know its an old issue, can u please tell me how to achieve it using stencil buffer …links will be gr8.

Stencil buffer? You mean antialiasing with the accumulation buffer?
There’s an example in the RedBook.

Also see this for all sorts of basics (chapter 9 for antialiasing):

Learn to use google.