Where is X11 devel on Mandrake 10.1?

I just installed Mandrake 10.1 (which works great, by the way), only to discover that I had no X11 developer includes etc. Under Mandrake 9.1, there was a package called XFree86-devel-xxxx.rpm, but I have not found anything similar under 10.1.

What are my options? Install the 9.1 RPMs? (has anyone tried this) Download the complete XFree 4.4.0 source (m.a.n.y MBs) and try to extract the necessary developer files?

Am I just missing something, or have they really removed the X11 developer packages/files from the Mandrake 10.1 distro?

Mandrake 10.1 is run with xorg instead of xfree. I am going through some growing pains now as well on it; gnome 2.8 install can’t find glu.h … I would tell you more if I knew


On my local FTP mirror, I found some RPMs in the 10.1 distro that weren’t on my ISOs:

xorg-x11-devel-xxxx.rpm (I think)

I haven’t tried it yet, but I will.

Regarding glu.h, I installed the nVidia drivers with the option --opengl-headers. Also, installing the nVidia drivers were not straight forward. Had to do some tricks (inclduing doing --extract-only + modify nv.c, found this on some nvnews forum).

EDIT: libxorg-x11-devel-6.7.0-2mdk.i586.rpm

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.