What causes these seams

I was using Blender which is an OpenGL based app, and noticed some strange problems with quads.

I made a small scene test with a textured plane:

Divided in 16=4x4 quads. The uv mapping applies unifromly to the entire plane covering the texture.

Next i scaled the vertices at the top to become very close. That produced the following shape.

The strange thing is that seams and strange artifacts started to appear.

I assume thats because these quads shapes are very close to triangles.

Im asking for some opinion on this, could this be because a natural limitation of CG and OpenGL when quads shapes become very close to triangles or do you thing it’s a Blender bug in the way it renders quads?

doesn’t blender have a forum?

Simple, bad uv’s, it happens, redo them.

The uvs where generated from a planar projection. Maybe the way Blender generates uvs is imprecise and the small uv errors get amplified when vertices are joined closed together. Is that what you are sugesting?

Edit: Nevermind, i think i found out what the problem is. My gfx card drivers (ATI radeon 9600 pro) is rendering quads as if they were two side-by-side triangles and that will cause texture distortions on the smallest triangle of the two. I should get a decent Nvidia card next time.

The screenshot looks very similar to perspective incorrect texture mapping. It’s caused by the fact that the quads are split into two triangles, and the texture coordinates are interpolated seperately and linearly.

Try to use a checkerboard texture, and you’ll see more clearly what I mean. The texture is correct at the edges of the polygons, but the interior is interpolated wrong.

While you are not using perspective, you still deform your mesh in a way similar to a perspective projection, so I think setting the texture coordinates as if this was produced by perspective will solve your problem.

However I don’t know how to do this in blender.

EDIT: Just saw your edit. Every graphic card will render quads as two triangles, that’s not a bug, and changing to a nvidia card won’t fix it…