weird error.

I’m trying to install a very high tech engineering software on a PC for work. I’ve been able to install it onto Debian Linux. When I go to start the program I get this

error:/lib/ undefined symbol: glPrimitiveRestartNV

I tried some diagnostics for myself.
glxgears works
glxinfo says I don’t have direct rendering.
I have a tdfx voodoo3 graphics card. using the tdfx driver, and am running on 32 bit. Thank you very much!


Hey, it is 3dfx, and there are no longer in business.
The missing call is from a NVidia only extension :

So you won’t be able to use it (maybe try with Mesa ?).

What is this “piece of software” ??

so do you think I switch video cards to an Nvidea card it will get rid of that error?
the software basically uses new technology to get a 3d model of an aircraft part and processed in such a way that it is able to be modeled.
I really can’t say much about it since I signed a confidentiality agreement when I took on the job, but this stuff is awesome!
Also, do you think there’s a way to use a primative for a tdfx card instead of changing the card to an Nvidia, can I change the software to work with my tdfx card?


>> relocation error: /usr/lib/ :undefined symbol: glprimativeRestartNV

I am replying to your post on user/gaming forum.
Is it really the error you get ? because it not glprimativeRestartNV but glPrimitiveRestartNV

Are you sure to have properly installed the nivida proprietary drivers ? (ie. ‘nvidia’ line instead of ‘nv’)

Actually I am using the nv driver, not the proprietary driver. Could that be my problem?

and yes it is glprimativeRestartnv and not glPrimativeRestartnv

I tried loading the Nvidia driver and it failed. Apparently it can’t find my kernel source on the nvidia website. I just checked the computers that this software is running on already and they are using the nvidia driver and not the nv driver. sooooo if I do find a way to upgrade the driver this might actually work!

If the nvidia installer can’t find a precompiled module for your kernel, you have to install the kernel sources so it can compile a new one…

You mean the actual source for the 2.2.20 kernel has to be somewhere in the filesystem? I’m sure it isn’t in /usr/src/ or something.

I don’t understand all. First you clame to be under glide (voodoo) and wonder if you have to change your graphic card, then you already have change it ? well, let’s assume that.

Generally, all linux distro provide a package for the sources of the installed kernel. So, install it.

yea I changed my Video card to an NVidia

Originally posted by <ElectronicTempest>:
yea I changed my Video card to an NVidia
Okay. And did you forgot your password ? That’s a bad idea thought :smiley:

To install those drivers, you’ll need your kernel sources. I also advise you change your kernel to a somewhat last version (2.6.x seems well). There are some bad things on previous kernels, like the power management not working well.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.