Vulkan Games Crashing Multiple Errors can't figure this out

Hello, I’m not a developer or anything I’m just a gamer and I have an issue with 2 games that run in vulkan crashing before loading. The first game “Bualders Gate 3” has the option to run it in directX or Vulkan. Game runs great in DX, if I switch to Vulkan it crashes on load. A newer game “Enshrouded” only runs on Vulkan and will not load at all. It crashes before I get a splash screen.
The Crash logs of the games both show it crashing during vulkan loading.

So far after a week of tring to read other forums to figgure this out, I can’t make any progress. I have reinstalled the drivers and installed the SDK and runtime but I just keep getting the same issues. Here is my top vulkaninfo from command prompt: (I can attach the whole thing if it would help)


WARNING: [Loader Message] Code 0 : windows_read_data_files_in_registry: Registry lookup failed to get layer manifest files.
WARNING: [Loader Message] Code 0 : Layer VK_LAYER_OBS_HOOK uses API version 1.2 which is older than the application specified API version of 1.3. May cause issues.
WARNING: dzn is not a conformant Vulkan implementation, testing use only.
WARNING: dzn is not a conformant Vulkan implementation, testing use only.
WARNING: dzn is not a conformant Vulkan implementation, testing use only.

Vulkan Instance Version: 1.3.268

The first Warning I have no idea… Second warning it’s calling for OBS but I do not use or have OBS installed. I have also never had it installed on this computer so IDK why its looking for it.

The next 3 with the dzn warning… The post below me in the Vulkan forum explained what is going on and was fixed in that thread. (Titled: Cannot create Vulkan instance) its very similar to the issue I’m having but the fix is to delete Open CL and I do not have it installed so there was nothing there to delete for me.

I have a year old MSI Titan GT77 HX with a RTX 4090 card in it. It’s supposed to be a bad ass gaming laptop but I can’t get it to run Vulkan games :confused: I have contacted MSI support, and they literally went right to Vulkan is a 3rd part software and they can’t help me. Then after looking up and showing them their warranty covers faulty graphics cards and that vulkan ships with it, there great tec tip was to reinstall windows and see if that helps…

Anyway, if anyone can help me out with this I would appreciate it.

You are not a developer, so do neither of those. It can only make things worse/messy. Try to clean up anything you desperately installed. Reset to Default if you messed with Vulkan Configurator beforehand.

The “D” in SDK means development. The runtime is provided only for special cases, and GPU driver packages already include better version that is more compatible with the driver.

The only thing on your PC should have installed is the GPU driver package. Normally that would be the latest downloaded from Nvidia webpage. But being laptop complicates things. Since it is recent laptop I would try the installers from MSI support page for now. Typically you need to install both the integrated (Intel) and dedicated (Nvidia) GPU drivers.

Please attach the part that lists Devices and also Layers to confirm the suspicions. Also check if it even finishes the log (or crashes or errors somewhere too).

It’s a screencap software. It’s open-source, and perhaps could be part of some of the other bloatware…?

Shouldn’t be on a computer that natively supports Vulkan. It is part of the Whatever Its Full Name Vulkan Compatibility Package.

Check for anything suspicious both in the new and Window 7 style installed app settings (they may subtly differ).

I mean, wouldn’t hurt to know if things worked at the factory state…

Thank you. So I looked into the integrated graphics side of it and there was a firmware update from intel that I think may be what solved the dnz warning. the dnz warning is gone but the games still dont work :confused: my vulkaninfo now only shows the OBS warning and the windows read file one. you might be right about seeing if factory state works. I guess I can try backing up checking and restoring… I dont really have that much bloat mostly just Adobe suite, Blender and steam. So it wouldnt be the end of world to just re instal a few things if factory works.