VK_PRESENT_MODE_FIFO_KHR does not work on NVIDIA Laptop

Hello guys,
as the title already says, the VK_PRESENT_MODE_FIFO_KHR does not work on my Laptop using a NVIDIA GTX 765M Graphics-Card.
Using this presentation-mode should cap the frames-per-second to 60 (monitor-frequency is 60Hz), but it doesn’t. It renders and displays always as fast as possible.
On my Desktop-PC with an AMD GPU this works as intended. I dont know if that matters but my laptop does not support “immediate-mode” but so it does with the “mailbox-mode”. In compare to my desktop pc which only supports “immediate” extra. Do you have any plan whats going on here?

Thanks in Advance :slight_smile:

It’s broken! (har har :lol:)

Seen it before: https://www.reddit.com/r/vulkan/comments/4gmugm/vsync_not_working/

Which platform, driver? Have you tried the official cube demo?

I’ve experienced the same on a desktop system with a NVIDIA card. The FIFO_MODE is ignored in the sense that it is never synced to the refresh rate of the monitor. But on the other hand, I never get visible screen tearing in any moment, so seems that IMMEDIATE_MODE is also ignored.

The cube demo works well. The driver is the last Vulkan update from July and the platform i use is 1.0.18, i know, it is outdated, but i’d say the problem lies with NVIDIA, not the platform XD

Installed new driver and now it works! THANKS NVIDIA!