Unable to get GL_VERSION 2


I have a clean install of Windows XP Home SP2, on a machine with a GeForce FX 5500 graphics card. This card definitely supports OpenGL version 2, as last summer I wrote an OpenGL renderer on the same hardware, but with a Win2k install.

On this clean XP install, with latest nVidia drivers (v169.21) I am unable to get anything other than v1 for GL_VERSION, and “Microsoft” for GL_VENDOR. I am expecting v2, and “Nvidia”!

It is my understanding that the installed nvidia drivers should route opengl calls to the card driver, so I do not understand why I am only getting v1.? Am I correct in this assumption? All I need is up-to-date drivers for my card?

I have installed the nVidia OpenGL SDK 9.5 too, and all the samples fail to run - “required extensions not found”.

What am I missing?


Hi spiral,

Looks like your system falls back to “software rendering”.

Hard to tell from here, but are you using 32 bit color depth (aka “Color quality”)? Speaking from my own experience, 16 bit does not work well (or even at all).

There’s an (ancient) tool called “PixelFormatEnum.exe” that shows you all available pixel formats and whether they use the “Installable Client” or “Generic Software” driver…



I grabbed the GLenum app from here:


It lists some thirty pixel formats of colour depths between 4 and 32-bit…all of them are listed as “not accelerated” !

I can’t believe this problem is to do with my using XP Home edition, or with the particular version of card driver I have (the latest) - but on a newly installed machine I cant think of any other variables?

Is DirectX working correctly? What does DxDiag say?



just to clarify: I’ve meant the current desktop color depth. Ensure that your XP is running “Highest (32-bit)”.

(Rightclick on desktop -> Properties -> Settings)


hals1010 - yes I have tried with my desktop set to 16 and 32 -bit.

dxdiag says d3d acceleration is enabled, and the d3d samples from the DX SDK all run fine, full acceleration.

what could be wrong with my OpenGL!?

Did you by chance get the latest Nvidia drivers through Windows update? (or run the updater after installing drivers?)

By default, the divers provided through Windows update do not provide OpenGL acceleration.

(Always get your drivers from http://www.nvidia.com))

Another suggestion would be to install older drivers from the Geforce 5 era before installing the newer drivers.

I always get my drivers from nvidia.com

I have installed the Geforce 4 MX series 93.71 forceware drivers, and I now have accelerated OpenGL 2.0

If I install the Geforce FX series 169.21 on top of the 93.71, it breaks again, so I am stuck with year old drivers intended for an earlier family of card - albeit, my OpenGL is at least accelerated!

On the off-chance somebody reading this is on 169.21, with an FX 5500, on XP Home - please do post to say whether you have/have not similar issues.

Thanks sqrt - your suggestion got me “up and running”.

Yet another step closer to buying a Mac… =)

Hi Spiral,

I have nearly the same Problem with my GeForce 8600GT.
The different is, that on a clean new Win XP SP2 everything is OK, OpenGL 2.1 works fine but on my Live-System runs microsoft generic OpenGL 1.1
I have allready installed the newest driver, dinstalled older driver with DriveCleanerPro, but nothing works.
I am searching the WWW since one week, but still no answer resolving this problem.

Hi Spiral,

sometimes everything gonna be good.
The answer of my Problem, was the ASUS Enhanced Display Driver Helper Service. I don’t know what it does, but after deinstalling this, the OpenGL setting is OK.
Now I have OpenGL 2.0

Maybe this solves your Problem too

Good luck

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.