Unable to disable antialiasing when picking points


I have a program that renders a large point cloud. When picking a point, they are rendered with an unique color to the back-buffer and the I read back the pixels into a buffer. It works for several computers, but for some reason I don’t get it to work with some laptops with nvidia graphics cards.

The main thing I think is that even though I have tried to disable all kinds of antialiasing stuff when rendering these points they still end up filtered in the buffer.
Than means the color is not preserved and I find colors not used when drawing the points.

I tried to do the following to disable the anti-aliasing for the points.
glDisable (GL_BLEND);
glDisable (GL_DITHER);
glDisable (GL_FOG);
glDisable (GL_LIGHTING);
glDisable (GL_TEXTURE_1D);
glDisable (GL_TEXTURE_2D);
glDisable (GL_TEXTURE_3D);
glShadeModel (GL_FLAT);

I also tried to disable all anistropic filtering and antialiasing via the nvidia control panel.
Nothing seem to work.

Please help me out here.

After hours of searching the net I found out that I needed to disable GL_MULTISAMPLE as well:


That did the trick!

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.