ubuntu opengl not supported

#1

I connect to my azure ubuntu server using tightvnc and open the terminal.

I check if opengl is supported using the fallowing command.

  1. First command using “glxgears” The results Error: couldn’t get an RGB, Double-buffered visual

  2. Second command using “glxinfo” The results name of display: :1.0 Error: couldn’t find RGB GLX visual or fbconfig

Is this mean that my ubuntu server doest not support opengl?

Also I tried to install QT creator to ubuntu server. I tried to create project and run it. I get error like

GLX extension not found

Is this graphics driver issue? how to fixed this

#2

Before you try to run a GL app on a Linux box through a VNC server/client, make sure it works when you’re logged directly onto the box and displaying on a local monitor. Get that working first. And note your $DISPLAY setting (e.g. :0 or :0.0).

Then retry via VNC, again noting the $DISPLAY setting.

#3

[QUOTE=Dark Photon;1291681]Before you try to run a GL app on a Linux box through a VNC server/client, make sure it works when you’re logged directly onto the box and displaying on a local monitor. Get that working first. And note your $DISPLAY setting (e.g. :0 or :0.0).

Then retry via VNC, again noting the $DISPLAY setting.[/QUOTE]

“make sure it works when you’re logged directly onto the box”
-> What do you mean I am logged directly onto the box?

“and displaying on a local monitor”
-> I am using microsoft azure ubuntu I dont have the computer locally it is on cloud.

“Get that working first”
-> How to make it work?

“And note your $DISPLAY setting (e.g. :0 or :0.0)”
-> What do you mean?

If i tried to type glxinfo the full result is.
name of display: :1.0
Error: couldn’t find RGB GLX visual or fbconfig

If i tried to type glxgears the full result is.
Error: couldn’t get an RGB, Duoble-buffered visual

Sorry cannot fallow you please make it clearer for me thanks.

#4

[QUOTE=barikdeveloper@gmail.com;1291682]“make sure it works when you’re logged directly onto the box”
-> What do you mean I am logged directly onto the box?[/QUOTE]

You said: “I connect to my azure ubuntu server using tightvnc and open the terminal.”
Instead: Go to your ubuntu machine, sit down, and log in directly to the terminal “without” TightVNC in between you and the machine.

“and displaying on a local monitor”
-> I am using microsoft azure ubuntu I dont have the computer locally it is on cloud.

Oh, I see. You don’t own the machine. I probably should have caught that from the “azure” mention.

Since it’s their server, you may just need to work with them to determine if/how they support running GL programs at all. This is Microsoft afterall, and they only begrudgingly allow anything that’s not Windows or D3D. What they do appear to allow, they’re often contorting into something else you can only get from Microsoft.

“And note your $DISPLAY setting (e.g. :0 or :0.0)”
-> What do you mean?

In your terminal session, on your TightVNC server, run this: “echo $DISPLAY”. My guess is you will find that it is set to :1.0 based on your error above. Your glxinfo output is basically saying it wasn’t able to find an acceptable GL implementation connected to display 1 screen 0. You can try running “glxinfo -display :0.0” just ot see if there is an acceptable GL implementation running on display 0 screen 0 which you have perms to access, but again we’re getting into questions of how Microsoft has setup these boxes.