system reset via simple GL program


unfortunately I’m able to reset :eek: my system (vaio fs115m) with a simple OpenGL program. I’ve already submitted a bug report but got no answer for it yet.

See here for the sourcecode:

nvnews thread

The program is started with “texturebug 1500” where 1500 is the number of 3D texture objects to generate.
If you use 1500 or more of them you’ll be able to reset vaio fs115m notebooks.

Whats wrong? Is anybody able to reproduce that bug or does anybody have solutions for it?

best regards,

I don’t know what bus or port the GPU is connected to on that mobo, but I do recognize the crash happens when there likely is no more dedicated video memory and the implementation is starting to evict textures - transferring them to system RAM.

I have seen problems with this ranging from random texture destruction, to solid system lockups, to spontaneous reboots (I was tempted to write “combustion” :slight_smile: )

There are many potential sources of the problems, but overclocking (running any of the involved system parts out-of-spec) is probably number one. Other candidates could be RAM not able to keep up with AGP transfers (please recognize the possible difference in access patterns and speeds here, compared to when the CPU shuffles data), errors in the AGP implementation (on the chipset, the mobo or the GPU) or even moon phase.

If this is an AGP system, I recommend you experiment with lowering the AGP transfer speed and/or fliping “AGP fast reads/writes” on/off.

Hi tamlin,

its a PCI-express GPU With 6200TC which in fact has only 64 or 32MB of onboard memory. Its a low end part so it is not really overclocked (i hope so), its a problem that arises only under linux, perhaps related to the kernel version. I ran memtest for 2 hours, no RAM problems. Perhaps the moon phase is not right at the moment. Should I circle a dead chicken above my notebook or does any other voodoo help ?


Should I circle a dead chicken above my notebook or does any other voodoo help ?

hahahahahhaa!! That’s funny. The mental image I had of that was great. :smiley:

Ok…I assume you tried doing this under windows also? What linux kernel version are you using? I’d suggest to download the source to the latest version (even unstable) and compile it, setup a new option in the boot loader to select the new kernel version and try that. I’ve had some really REALLY weird problems with some kernels before. Like this one time, at band camp…errr I mean this one time this particular kernel version wouldn’t let me write a program that needed two files open at once, yet it worked every where else. Upgraded the kernel and poof, everything A-OK.

That sure is a lot of 3d textures. 1500 :eek:


Originally posted by mlb:
Should I circle a dead chicken above my notebook … ?
Considering this is a PCI-express notebook, would a chicken really be enough? Do you have access to a goat?

If that fails, you could as a last resort (I take NO responsibility for this) try hovering an OS/2 CD above it, making it perfectly clear where you’d try to install it if this continues. You might prepare for ill-effects with a few large plastic bags, as IC’s are known to eject the smoke that makes them work just before they go catatonic. If you get smoke from this procedure and find a way to put it back in, let us know how you did it.

What I’d like to see is if you can provoke this reboot using just 2D textures too. As you have relatively little memory on the card, it seems the VRAM -> RAM transfer already works, but a border-case seems to fail in the most spectacular way. I wonder if those border-cases could be when all memory is exhausted and swapping is about to start.

In addition to SirKnight’s advice, both to test using Windows and to recompile a new kernel, I’d also add “and don’t be shy adding liberal amounts of debug tracing to a kernel you compiled yourself”.


problem resolved. That’s how the voodoo goes: It took a living goat and three dead chickens. Fix the chickens on the ceiling above your computer so that they can freely circle hanging above it during the procedure. Then let the goat walk around 13 times around your computer, counterclockwise. Then, if you use the mandriva 2.6.11-6 linux kernel, update to NVIDIA 7664 drivers :wink:


(seems to be a problem of 7174 with that kernel).


unfortunately I now got a system reset with the 7664 drivers too. So it seems to be a problem of both 7174 and 7664 driver combined with 2.6.11-6 kernel (and probably pci-express). See nvnews thread for more infos…