Strange DRI problem

I have a program that works perfectly without DRI. When I enable DRI… (and I enable it correctly since all the demos work and very fast) the program simply doesn`t show anything in the screen. I tried to debug… and discovered it just stop as soon it reaches any gluPerspective() call.

Any Idea? I already spent two weeks on this problem… and I found nothing wrong with the code (since it works with non DRI and in windows too)

Sounds strange… perhaps a mismatch between the library and the header? It could also be a corrupt file, have you tried to reinstall GLU?

What do you mean by ‘it stops’ ? Crash ? Block on a function call ? Exit properly ?

That is the most strange thing… it just stops. No error messages, no crash, the window still there… but the program doesn`t go further. A printf before the call is printed… a printf After the call is never called.

If I try to debug it… when the line is reached and I ask for the next line… it just stays there… and do not advance.

What is the instruction stopping the program ? What is the state of your process (use ‘ps x’ and report the letter in the STAT column) when it is blocked ?

i don’t know, but that’s maybe a pointer problem: i had a similary problem while using voodoo2 with ATI. But the stop wasn’t on gluPerspective() but in initialization.


i forgot:

I hope you haven’t got a Nvidia card ?
if you get one, just forget DRI; it won’t work !

ps: that’s just the case where…


I have a NVIDIA in one computer and a radeon at other. The problem is with the radeon

any other similary calls to gluPerspective() do the same thing (gluLookAt, glFrustum()…) ?

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.