slow GLX


I am trying to play this game (Tuxracer) which requires GL drivers. I included in XF86Config that GLX should be started. This is a problem that goes for everything that requires GL. I am currently running Xfree86-4.1.0, Slackware8.0, kernel 2.4.16 (patched with ipsec)
I.e here is ldd of the tuxracer binary; => /usr/X11R6/lib/ (0x40022000) => /usr/X11R6/lib/ (0x4002b000) => /usr/X11R6/lib/ (0x40041000) => /usr/X11R6/lib/ (0x4011a000) => /usr/X11R6/lib/ (0x40122000) => /usr/X11R6/lib/ (0x40130000) => /usr/X11R6/lib/ (0x40146000) => /lib/ (0x40190000) => /usr/lib/ (0x40194000) => /usr/lib/ (0x40217000) => /lib/ (0x4029a000) => /usr/lib/ (0x402b0000) => /usr/lib/ (0x402e8000) => /usr/X11R6/lib/ (0x4034f000) => /usr/lib/ (0x403cf000) => /lib/ (0x40415000) => /lib/ (0x40437000) => /opt/gnome/lib/ (0x40548000) => /opt/gnome/lib/ (0x4054f000) => /usr/lib/ (0x4056c000) => /opt/gnome/lib/ (0x405c2000) => /usr/lib/ (0x405da000) => /usr/lib/ (0x405e0000) => /usr/local/lib/ (0x405fa000)
/lib/ => /lib/ (0x40000000) => /usr/lib/ (0x40659000) => /usr/lib/ (0x406ba000) => /usr/lib/ (0x406c0000) => /lib/ (0x406c4000)

As far as I can see, there’s nothing wrong in this output. Does anyone have suggestions, or even links I may refer to that explains this type of problems?

In advance, thanks for all help!

you forgot to mention the most important bit of information, what video card you have. if its an nvidia card, go to their website and install their drivers. if it isnt, make sure you are loading dri when you load glx. in the XF86Config file, add:

Load “dri”

right after the glx line. if that doesnt work, go to (again, if you dont have an nvidia based card).

I remembered that as I hit “Submit”…anyway, I’m running a Geforce2 video card, and I have previously tried to install the new nvidia drivers. The reason it never worked is that i have a somewhat snif unusual system structure…I just downloaded the latest drivers, changed the Makefiles and installed…it worked perfectly :slight_smile:
Sorry to be a bother, and thanks for the quick reply :slight_smile:

no problem

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.