SDRC/I-DEAS won't run under OGL 2.0

Hello… I’m searching for help. First, I am not a programmer but hopefully someone on this forum will have a suggestion or solution.
I have SDRC/I-DEAS 8m2 installed and have had running for 9 years on a VGA card that supports OGL 1.5, which matches the driver that I-DEAS 3D software needs. It should be noted that the I-DEAS software is not up-dateable. I’ve recently purchased a 2707WFP Dell flat screen that runs in VGA or DVI and have been using the VGA connection run from a ELSA Gloria II 64 meg video card. The video card runs and supports OGL 1.5 and does a credible job in support of I-DEAS software. In trying to optimize my work and the ability to use the DVI monitor port, I purchased and installed a GeForce 7300GT AGP video card with a DVI port which is compatible with the 2707WFP monitor. All printed matter indicated that this card should have no problems running my CAD package, I-DEAS… This wasn’t, and is not the case.

I have tried another video card, a QudroPro2 64 meg DVI – which runs the I-DEAS software but doesn’t drive the monitor at the required 1920x1200. The resolution selection allows this res capability, but for some un-wordly reason compresses everything into a centered band in the center of the screen. So this card does great on other resolutions but at different resolution’s, cause object distortions – rounds aren’t round and squares aren’t square, that type of thing. This card also supports OGL 1.5 as does the Gloria VGA card. I would have used this Quadro card if only the darn thing would run the 1920x1200 resolution – no luck. I have updated the monitor profile so I don’t think that is the screen compression issue – not really sure.

I have now re-installed the GeForce 7300GT AGP 512meg card thinking that I may have missed something in the Nvidia control panel in application selection – I haven’t. The CAD package selection simply isn’t there. Lots of what appear to be games, or something like that, appear in the application selections, but no CAD package selections at all. Today I have started to experiment with forcing different older video drivers to work with this video card per suggestions from EVGA. Nothing I have tried so far is hooking-up with the 7300 card. A few video card drivers have tried, but no luck. I went to the NVIDIA web site and have been downloading anything that has OGL 1.5 or less in the driver description and trying to make it work with the 7300 video card, whether it is for this specific card or not. The 7300GT card appears to be OGL 2.0 and it simply does not work with I-DEAS software.

I’ve been installing, un-installing video cards and drivers for the past week with no luck at all.

Here’s my question: Can I somehow force, overwrite or replace the OGL 2.0 with OGL 1.5 so that I can use the 7300GT AGP card to run I-DEAS software? Is there such a thing?

My OS is Win2K with AMD processor.

ANY assistance would be greatly appreciated…
Thomas Designs

OpenGL 2.0 is backward compatible. It could be possible that the cad application checks only if the version number is equal to 1.5.
You should post the error mesage if possible and you could write a bugreport to nvidia.

Thanks oc2k1… Unfortunately, I’ve been to Nvidia and thier news groups with no comments or suggestions to date. Also have opened dialogue with EVGA, they sound as if they don’t do any design interfacing with Nvidia and are pretty much just a reseller. They don’t have any applications people.

I have tried these folks but to no avail:…sult_type=posts

Nvidia, the company, doesn’t have an avenue to their design or engineering staff – at least that I can find. This time I thought I would go directly to the source of OGL, this group.

I think I have exhausted all avenues, including myself, in this effort.

Here’s the best I can do as far as screen captures:
(I have images but can’t get them to post)

When I press the shortcut to I-DEAS software here’s what comes up, all normal except that the line where the cursor is there should be a line that reads/says: “ You are running I-DEAS with open GL.”

The processor stays pegged at 100%:
(I have images but can’t get them to post)

And here is what appears to be the OGL/I-DEAS *.dll:
(I have images but can’t get them to post)

I also have transcripts of all my conversations with EVGA if you would be interested.
Thanks again!

Perhaps your drivers are not installed correctly.

Try running this app:

Then paste the string you see here. Mine is:

Vendor: NVIDIA Corporation
Renderer: GeForce 8600 GT/PCI/SSE2
Version: 2.1.1

The important line you need to see is “Vendor: NVIDIA Corporation”, if you do see this, I’ll see what else we can try.

Did you try this driver or another one?

sqrt, NiCo… Let me go to work on your suggestions… Thank-you VERY much!

Here’s the drivers that I have tried:

Nvidia 56.72, 71.89, 76.2, 71.84, 169.21 and the monitor profile from Dell is a zipped file that was extracted and applied;

The 76.2 (for 7300 card) runs all other non OGL apps – really nice, crispy results at 1920x1200 dvi.

The 169.21 works with the 7300 card but, again, not the OGL as related to I-DEAS software.

These are the only two that have loaded and run, no aborts. I should mention that I un-install any previous driver before attempting to load a new one. Frankly, I don’t know if there are still reminant dll’s lurking somewhere that find a way of cross talking with any new trial run or not. I trust that the un-install routine is really un-installing.

Thanks again!

I’ll report later

Greg T

And as said sqrt-1, what information is returned by glinfo2 ?

Okay, here’s what GLinfo returns:

Driver version:
Vendor: Microsoft Corporation
Renderer: GDI Generic
OpenGL version: 1.1.0

Greg T

Hello… I’ve decided to give up on this effort. Been struggling all day and to top things off, I performed the old dropped screw on the motherboard trick. Now I can’t find it, even after totally dis-assembling my workstation. It’s been a true grief circuit, but sincerely appreciate everyones assistance –

I’ve went back to the ELSA Gloria II VGA card. Runs just great but no DVI… I’m bummed…

THANKS for all your help!
Greg T

That is a pity - that log indicates exactly what you problem is.

If you are still reading this - seeing Vendor: Microsoft Corporation means the diver is not installed correctly.

This typically happens when you switch between vendors of video cards and the old driver has not un-installed correctly to allow a new driver in.

I don’t know a specific way to fix this - but most people resolve it by re-installing their OS and ONLY installing the drivers for their new target card.

Sqrt… Hey, Thank-you! I guess I’ll be rooting around the MS site for some answers because I can’t replace or reload Win2K and expect my 3D modeling program to run again. Licensing issues would become cumbersome.

There must be a way to replace or overwrite the stock OGL prerequisites – there must be. I’ll keep doing the research and move slowly.

Zbuffer… I did try that driver set you mentioned with no luck.

Thanks again!

Greg T

OK if you cannot re-install your OS you will probably have to manually edit the Windows registry.

Click Start->Run and type “regedit” then click OK.

Navigate to the folder under:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\OpenGLDrivers

Sub-folders under this location list the different OpenGL drivers installed. The one for Nvidia is called “RIVATNT” and should have the properties similar to this:

If there are any other sub-folders under “OpenGLDrivers” delete them. (actually could you also list their names as a reference for other users?)

If you want to back up the extra registry folders before deleting them, Right click on the folder and select “export”.

Note that messing with the registry is a very dangerous thing to do - as you can easily mess up your OS. (I am not a windows expert by any means)

If this does not work - try deleting all driver registry sub-directories and re-installing the Nvidia drivers.