runtime error, GLX?

Hi, on Fedora 10, I can compile opengl code without errors but get the following runtime error. It’s the same error on many different opengl programs and variations that I’ve tried.

X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  19 (X_GLXQueryServerString)
  Serial number of failed request:  12
  Current serial number in output stream:  

Some suggestions would be great.

btw, I get the same error just running glxinfo from the terminal.


you should provide more information on your problem.

I don’t know how to solve it but I have also had the same problem, also on Fedora 10.

What GPU do you use?

I had that problem using an ATI Mobility Radeon x1600 at an HP nc8430. This would only happen after installing the ATI’s fglrx driver.
Searched everywhere and found very few possible solutions. The ones I tried didn’t work. In the end, I gave it up and am using Kubuntu.

I guess I will try again on next Fedora release… It was my first time using Fedora and I liked it, just cound’t get past installing ATI driver on it.


ATI Radeon 9550. I installed their drivers too. Before that I couldn’t compile the code so amn’t (you know, am not) sure if I had this problem before the driver install.
I’ll quote you a line from a reply to my post on

It’s possible that you may not have hardware 3D acceleration (DRI) enabled in your X server or kernel, and that your code needs it enabled.
Do this in a terminal window:

xdpyinfo | grep DRI

If it shows “XFree86-DRI” as output, then you have DRI enabled. If it comes back empty, then you don’t have DRI enabled.

I get empty. And am in process of figuring out how to enable DRI. I’ll post it here when I know.

Run ‘cat /var/log/Xorg.0.log | grep dri’. This will give you an idea why you DRI doesn’t get enabledo.

It’s typically a problem with the kernel module - it could be left over from a different driver version, it could be missing a symbol or it could be compiled against different kernel headers than your current kernel.

Yep, did that and it told me the kernel possibly needed updating or some such thing. I was given a link on fedoraforum to this ATI driver install howto and it’s all good.