Removing mesa and installing radeon drivers to run open gl apps

Hey guys, need some help here

I have SuSE 10.0, and have some problems playing 3D games due to the error “No 3D card is availabe or 3D graphics aren’t configured yet”

I know that a possible sollution is ot install the correct ATI drivers for my card, and have tried to do so. but every time i run fglrxinfo it tells me the mesa drivers are there.

How can i get rid of mesa from my system for once and for all, and install the radeon drivers.

System info,

AMD Athlon 2600+
SuSE 10.0
Radeon v250 chipset, 9000 pro.

And the data i get when running Fglrxinfo:
display: :0.0 screen: 0

OpenGL vendor string: Mesa project:
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

Cheers, Mark

go to from the “Drivers & Software” menu choose Linux, then
click on the “Linux Display Drivers and Software” link, and then “RADEON 8500 Series and higher” -
that should take you to the driver download page.

find the driver for your version of XFree or xorg and install it.

I have a similar problem:

I did what you said above, and when i try installing the drivers, they said that it’s conflicting with the Mesa libGL package…
so, is it safe to just uninstall the Mesa libGL package and install the ATI ones?

I am not sure it is really safe to delete Mesa.
I just left it and installed fglrx rpm.

Mostly, “dri” kernel module is failed to load. Check here to install fglrx properly:

I had lotsa trouble installing the ATI drivers under Suse 9.3, but I eventually got them installed. They are hard to install due to misleading documentation ATI has a really stupid attitude about helping their users - the main reason I’m up for an Nvidia product as my next graphics card…

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.