Redhat 9 linux/4496 3d doesn't work

Hi. I have a problematic redhat 9 computer where 3d opengl refuses to work. Specs:

distro: redhat 9 (updated with apt-get)
kernel: as per original distribution
hardware: abit nf7-m onboard geforce 4 mx graphics
driver: nvidia 4496

The problem that I get is that 3d opengl graphics don’t work, and crash the entire computer. E.g. if I run glx gears then the gears appear, and rotate irregularly a few times, and then X locks up. Since I can’t move to a text console, I presume that the entire computer is locked.

I don’t think it’s a hardware problem as once in a previous installation of rh9 (before I tried to upgrade glibc “in place” and ruined it), I had 3d graphics working, could use celestia, tuxracer, etc. Also, when I tried a mandrake install on a spare disk, and installed the drivers, 3d worked on that. I have replaced the gl header files with the nvidia ones, and even recompiled glxgears, with no improvement.

I haven’t upgraded/replaced glut from source. Also, I note that someone mentioned that it’s best to remove all libgl libraries (and links) to make sure that the software ones have gone, and then reinstall the nvidia drivers.

I’ve tried comparing my libraries on my work (rh9, geforce 2 onboard video) computer to that at home, but writing a program that red all of /lib/* and recorded file sizes and checksums (i.e. works for symbolic links as well). It could find no difference between home (screwed) and work (works perfectly).

I tried asking questions on the nvidia linux forum, but despite many people trying, I haven’t even found a clue as to what might be wrong.

Can anyone suggest anything that I should try?

Thanks in anticipation,


Personally, I had many problems with 4496 using GeForce FX 5600 Ultra on RH9 using originial kernel and several updated kernels since. It never worked hardware accelerated and always forced me to use software emulation. Everytime I rebooted I had to reconfigure for software or reinstall the driver. It would not recognize the driver=nvidia parameter in the XF86Config file and the X server would crash at boot and sometimes while I was working. However, I was always able to get into a text console using the Alt-F1 keys. My only solution was to go back to 4363 which works great for my purposes so far. Hopefully they will fix the issues for the next driver release.

As for gears… I have always had some problems with its stability though it would never crash the system completely but it would sometimes take out the window system which meant I had to go to a text mode console (Alt-F1) and usually change my run level to 3 and then back to 5 or just restart the X server.

[This message has been edited by shinpaughp (edited 10-22-2003).]

Hi. It is possible to get opengl working on my computer with redhat 9, as I’ve done it before. I certainly can’t repeat this feat though. Last night I tried a fresh install on a new disk. After a typical workstation install, I tried installing the 4496 drivers, and still no joy with glxgears. Crashing the whole computer as before.

The next thing I was going to try was to do a fresh install of severn beta, and see if this fixes the problem.

I did find that installing Mandrake 9.1. on a fresh disk did work. But, I’d rather fix the distribution line I’m using rather

I note that someone else posted that Mesa seems to be the way to fix redhat 9/opengl. Could someone please advise what I need to install to try this for myself?



I have a nvidia fx 5900 ultra on redhat 9. Redhat does seem to have upgrading from previous versions to later versions I usally do a fresh install when I upgrade. Make sure you have the latest updates from redhat(use up2date) and the latest nvidia linux drivers installed, do EVERYTHING that the nvidia readme says or you’ll run into problems. When you say “linux locks up” I doubt this is true, linux has never locked up on me. Hit Ctrl+Alt+F* (below 7) login as root and type ps -d find were ever glxgears is and do there should be a number next to it type kill -9 num. Then hit Ctrl+Alt+F7 and your back into X. You can also find X and kill it or type reboot to reboot your system.

Linux has locked up on me and the reason was the AGP settings for the nvidia driver. Try to disable AGP as described in the documentation from nvidia.

I have seen this same problem with RedHat 9. And the virtual consoles do lock up. I have been able to ssh into the box and kill the guilty process. What I have found is that X is hung up trying to request a buffer from drm. I will try and submit the backtrace later.

I’m also having problems with 4496 that weren’t there with previous drivers, or if they were there they were very, very rare. I’m using Mandrake here. Though I didn’t try to disable AGP as recommended by the readme (and as pointed out here too).
Anyway, when the X server freezes, I never have to reboot the whole system. Just hit Alt+Sys+K in order to kill the X server and you’ll get back to the login screen. Obviously, you will lost any work done by applications using the X server, but at least that’s a chance to get back to work very quickly.

Well, in my work my RH9 works fine with the GF2MX. Look at the X log, is there anything unusual?

And n fact is pretty easy to loack a Linux system… If you have acces to a system feature like VGA you can lock any SO in the world.

But a friend of mine had similar problem with his RH9… then a time later it came to work again…

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.