problems with Radeon 9800

Hi, I´m looking for someone to help me, I just got a new computer with a Radeon 9800pro,but everytime I try to play an OpenGl game I get corrupted graphics, I have
tried everything, updated my drivers, tried to download the GLsetup but it doesn´t support windows xp, somebody knows what can I do?

Thanks a lot.

Did you try catalyst 3.5?

I’m having the same problem, corrupted textures on any opengl games i try to run on my 9800 pro. I have the latest (3.6) catalyst drivers, and GLsetup isn’t supported by Windows XP. Anyone know how to fix this problem?

Yeah same here…even now i have the catalyst 3.8 drivers, but textures are still corrupted in many games (Freedom fighters, UT2003) and to be honest, it’s damn annoying

I am having the same exact problem with my AIW 9800 Pro. If anyone knows the answer for how to fix this, please email me @ wocket @ sc . rr . com (seperated to stop spammers)

Well seems like we all are suckers, i also have a Radeon 9800 Pro and i cant either play with openGL.
Radeon sucks…

Same prob here folks. ABIT NF7-S board, AIW Radeon 9800 Pro, cannot even start Serious Sam, Quake 3, SOF II. Right as soon as I start any opengl based game I get the message “Application error … blah blah… memory could not be ‘read’ …blah”
As a work around, I used Partition Magic, chopped up one of my spare 15 GB partitions, loaded Win 98 SE on it, and play games from that OS. No issues so far. Hope this helps everyone.

“An infinite number of monkeys typing into an infinite number of computers could eventually produce Windows XP… and they did”

Hi guys, you wouldn’t have any problems if you have nvida card!!!..but, why Radeon???. Welcome to Radeon’s Nightmare. Only the drivers name say all: “CATALYST”, bufff!!!

cirityone says:
“you wouldn’t have any problems if you have nvida card!!!”


“OpenGL applications may exhibit Access Violation errors upon rendering a scene that consists of very long spline lines in a model or bitmap. This issue is not specific to ATI, and can occur on any graphics card under Windows NT, Windows 2000, or Windows XP.
This error occurs due to an inaccurate calculation of the coordinates for the long line”

This is a Microsoft issue, not ATI. Not that I carry either in high regard, but can someone post an intelligent or helpful response in this thread?

“Da molister”



I was able to resolve my opengl probs. All opengl (and directx games) work great now. What I did was install the drivers that came with the card (Catalyst 3.4). As strange as it sounds, they are better than the newest drivers (3.9). I hope this helps others. So much for the theory of having to update to the lastest and greatest drivers for ‘best’ performance.
Now then, with everything 100%, where is that poor bastard that owns an nvidia card? Me thinks the moment of truth has come, time to smoke some ass.
Perhaps he is gone, never to return. He may have gotten a life. If so, he will have no more time to read forums for hardware he doesn’t even own. Of course, reading about other’s problems with superior hardware may have comfort value :-p

Thanks to all who gave advice in this forum.
Lata gatas.

“Da Molister”

Hi, don´t cry any more Mollister, you always can come back and begin to begin with your old CATALYST drivers. No more speed, quality and performance, no more features, time to time. Many people have Nvidia cards and Radeon cards, time will give the reason.

Man. The fx5900SP is crappy. I tried all I could to put it to work for at least two weeks. I’m changing it to a ATI Radeon 9800Pro 256. I hope this babe works better.

Sure, the pro could be with the card, but since the MSI guys uses that random answers generator for their tach support, I decided to quit the card.

Hi all,

I have a nvidia ti 4200 8x agp I purchased about six months ago, and now I’m having major problems with it. I’m not alone, here is a forum with similar issues:

I’m doing research on other video cards, hoping to find one that will last longer than six months.

Do you all recommend the Radeon 9800?

Disregard my last message, I already bought the Radeon 9800, cuz the nvidia ge4 ti 4200 SUX!!!

Hello all.

What kind of texture corruption do u actually mean ? clipping errors ( so textures dont stop where the vertexes do ) then u should see if Fast-Writes is enabled.
Also within the catalyst driver package u can use smartgart to see how the setting are. Smartgart is in the video settings, But u can also go to start->run->smartgart, to uncover some secret extra setup utility. I have the experience with smartgart that Fast-Writes makes a lot of trouble. Go mess around with some Bios AGP and video settings, and do the same with the settings of your ati card. After a couple of reboots, everything must run.


BEWARE! I own a Dell Optiplex GX270 and the Radeon 9800 has a significant problem with at least the GX 260 and 270. It simply wont power up. the issue is clearly with the Radeon card in this particular Dell config. After days of problems and tech solutions that didnt work I switched to the GeForce 5900 ultra whose power requirments are even steeper than the Radeon. It booted no problem and is functioning very well in all applications.