problems with antialiasing of lines

Hi, I’ve looked through the archive and I’m aware that this topic has come up before, but not recently. I was wondering if a good solution has been found.

I would like to antialias the lines that I am rendering, their thickness can be set from 1 to say 12. The problem that I see when I render the lines is that they do not appear to be continuous. Some of the background comes through where the lines join or overlap.

The only way I can negate this effect is to turn off blending when I render lines. Obviously, the lines then look quite bad when they are close to horizontal or vertical.

What I am asking is, is there a definitive solution to this problem? How can I introduce antialiasing of lines and not see the effect that I am getting?

Any assistance at all would be great.