Problems enabling GL with radeon

tried to make the DRI work following the instructions at the DRI site. glxinfo informed me that DRI is not working… I checked everething and the only thing I could find out was that agpgart was not among the loaded modules. I tried to load it… but received a no such device error… does anyone knows what is the problem… I even looked at agpgart code to discover… but I could not find a solution.

Just updating… changed some things in aggart code and it loaded… in a “try_unsuported mode=1”

I get from X the following messgaes:

(EE) RADEON(0):[agp]AGP not available
(EE) RADEON(0):[drm] Failed to remove DRM signal handler. DRI unlock called when not locked

I have a RADEON 7500 in a ASUS a7M266 (AMD761)

I think it should work and I am really dissapointed with it. Does anyone had a similar problem? I have no more ideas to use… May be the motherboard chipset?

If you’re hacking the code to work then you’re asking for trouble… I have a 7500 and the DRI drivers are great. From what I read in your post you don’t have AGP enabled in your kernel. check dmesg and you should see something about the AGP interface and its aperture.


It looks like AGPGART doesn support my mother board chipset… but in the code it says that supports AMD 761MP that has exactly the same northbridge. cause that I am hacking the code to make the agpgart think my chipset is a AMD761MP ( I am not asking for trouble since my job is that and I work in a software hardware integration lab)

What motherboard do U use?

i have read in a magazine (for not naming it: Linux Magazine) that for ATI Radeon cards, you need to disable the DRI support for your kernel.
you only need to use the DRI support for X.

don’t know for the AGPgart kernel…

and i think there are some manips to do.

that’s just what i remember, tell me if you need more.
i’ll try to bring the magazine tomorrow.

I still think is a agpgart problem… I could not make it load.

There are a couple of known problems here that you’re probably not aware of. There are problems with the DRI drivers in the XFree86 4.2 (and previous) release and the 2.4.18 kernel with the Radeon 7500. There are efforts afoot to fix the problems with the 7500 and enable T&L support for both the 7500 and the Radeon “classic.” It is not yet known if these changes will make it into the XFree86 4.3 release.

Additionally, there are known problems with all Radeons and the AMD 761 chipset. There was a recent thread on the dri-devel mailing list (see link below) on this subject.

Hope this helps.

Thanks a lot!

Finnaly I got it working. But it is still limited… stencil buffer doesn`t work… does the features in ATI boards + Linux are cripled like that?

I dont know the answer to your question, but you may have a look at the features of the driver offered by - if they have a support for it, so the problem is SW…

By the way this thread is quite interesting for me, I intend to buy a laptop with ATI Mobility Radeon 7500…

Regards Martin

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.