Problem with glut

I’ve been trying to do compile and run the program in this tutorial:

When I compile my program, everything is fine, but when I proceed to run the program… nothing happens. A black window is supposed to pop up, but it doesn’t.

This was in eclipse, so I figured that maybe it just wasn’t good with displaying gl stuff, so I went and just used the executable that it generated for me, and when I run that it says that it could not find glut32.dll. I know for certain that glut32.dll is in my PATH, in system32 specifically.

Is there anyone that can help me out?

A quick hack to fix this problem. Put glut32.dll in the same folder as the executable.

Other than that, if if can’t find the dll, the path must be wrong. :slight_smile:

Putting glut32.dll in the same folder did work, and I’m thankful that I can verify that everything else worked fine.

I’m so puzzled about this whole not finding glut32.dll. system32 is set as part of my PATH by default by the system settings, and glut32.dll is definitely in there, the same glut32.dll I just used to put into the folder of my executable.

Update: Ok, I put it into a place in my path that wasn’t system32 and it worked fine. Which is sort of strange, but whatever, at least it works now.

nice. :slight_smile: