Problem running vulkan on macOS and vscode

I’ve installed the vulkan SDK to my Mac mini but unfortunately I can’t get it to run with my makefile. Seems to be an error finding libvulkan.1.dylib.

I provide a link to the lib folder but still it doesn’t work. I’ve been through and setup all my environment paths as explained in the install guide on the lunarg website but to no avail.

Strangely the vkvia and vulkaninfo verify installation apps also fail to run. Get command not found error. Really bizarre. I’m quite new to macOS and I also have homebrew installed, which I’ve read can cause PATH issues.

Anyone any ideas?


Wow. This forum’s lively. Seems I get the same error in xcode even with the correct library paths. Possibly something to do with my Vulkan installation? Strange thing is the doesn’t execute either. I’ve tried reinstalling zsh and installing the zsh add on but to no avail. Anyone any ideas?

Two suggestions:
1/ Don’t criticize the community you are trying to get help from :slight_smile:

2/ Actually show the errors you get and the steps you took to get them.


I’ve actually got it work now - sort of. It seems xcode won’t allow me to add both the libvulkan.1.dylib library and the one it points to. The guides online show that both are required. Interestingly if I rename the file (libvulkan.1.3.261.dylib) in library/developer/xcode/… to what it is looking for (libvulkan.1.dylib) then it works. Once you clean the build though and rebuild it only copies the first library and not the alias. But it’s the alias that its looking for. Chicken and egg. Anyone else come across this weird issue or is it just me?

I managed t osolve the issue in xcode by dragging in both libraries into the ‘Link Binary With Libraries’ section. Adding them individually didn’t work as it would only allow one of the files as the alias links to the other vulkan library. Dragging them from a macOS window straight into section worked perfectly. It now builds and runs successfully.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.