Please Test My Game

I’ve never released a Linux binary before, so I’m not sure I did every okay. Could somebody please d/l and lemme know if it runs okay? Thanks!

Oh. It requires SDL to run. I dunno if I should include that or not. It’s available at:

[This message has been edited by mv (edited 07-07-2001).]


yes, it works out-of-the-box for me. One suggestion: make the archive extract into a separate directory so that the game files arent scattered in the current dir (ok, there only three files…but nevertheless it would be better).

Other than that the game runs quite perfectly on my box (athlon 700, tnt2, with xfree4.0.2 and the newest nvidia-drivers…). I get around 80 FPS in 800x600 resolution…

Oh, I think I found a bug too: When you enter your name for the highscore-list, the characters disappear and an entry with empty name field appears in the highscore list…

bxe Miq

Thanks. Hmm… I’ll look into that bug. Yeah, I realized after I should put it in a directory and tared the directory.

I also realize now that I should mention it’s compiled for intel as opposed to PPC or Alpha. I’m reluctant to release the source code till after I’ve finished the game, so I suppose the alpha/ppc linux folks’ll have to wait.

Didn’t work for me. You’ve linked it against libGLcore (which is not present nor necessary on my system - older X).

I don’t think you should have -lGLcore on your linker command line; if libGL needs it then libGL will be linked against it.

I see. Well, I knew problems were bound to crop up. I’ll re-compile and u/l it again later today. Thanks for the info.

Okay, I’ve fixed the name entry bug and repackaged the tar file to have a top level directory. I looked and I’m not linking against libGLcore.

the only libraries I’m using are:
-lGL -lGLU -lSDL -lm -lpthread

I’m linking directly to libSDLmain.a which is just how SDL wants things to be, but I don’t think it’s causing any problems.

I DO see where ldd reports that is needed by barrel_patrol_3d, but it says the same thing about by That is, if I run ldd on it reports a number of libraries needed, libGLcore being number 1 on the list.

This sort of stuff was bound to happen, I suppose. I did reshuffle some things and removed some seemingly useless library inclusions. I also recompiled with O3 and g0. Wanna try it again and see if it’s the same? I’m guessing it is, but who knows?

Thanks for the input. I know it’s annoying to hassle when people don’t seem to have their sh!t together, so I do appreciate the effort.

OK, I took it home and ran it on a GF3+X4.0.2 - slick as catsh*t on a lino floor.

Got your new download and tried it on this X3.3 box. I no longer get linker errors about GLcore, but this:

loaded object_missile_1 : 4332 bytes
loaded object_tank_1 : 19592 bytes
./barrel_patrol_3d: error in loading shared libraries: /usr/local/lib/ undefined symbol: XF86VidModeQueryExtension

SDL is installed, but I suspect that (because of my older X) when I configured/built SDL it left that particular bit of functionality out. Is it necessary for the game? If not, you might have more luck with people running X3.3 if left out.

If I objdump libSDL and look for that symbol:

obelix:/usr/local/lib> objdump -x | grep XF86VidModeQuery
00000000 UND 00000000 XF86VidModeQueryVersion
00000000 UND 00000000 XF86VidModeQueryExtension

So its not explicitly not there :frowning:

Hmm… I think may be a little beyond my depth. I compiled using the latest version of SDL – 1.2.1. Could it be that you’re only at version 1.2? I think SDL checks for valid resolutions prior to attempting a change, so I dunno if you can eliminate that or not. I take it, it didn’t run on the X3.3 system?

Out of curiosity, what version of Linux are you running? I compiled under Debian with it’s latest/greatest/unstable parts for the 2.2 kernel. Just curious what I can sorta “claim” as far as compatibility goes. I’m finding the Mac version is proving to be a little more difficult to wrangle.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.