pBUffer crashing problem


I’m running an OpenGL application on NVidia Quadro boards with Dell workstations and having some problems with pBuffers. I’ve written a sample application that shows that if I create a pBuffer, allocate a whole bunch of texture objects, and then switch to the pBuffer’s context then I get a crash of my X server. This happens every time. Changing the code so that the pBuffer’s context is made current before allocating all of the textures seems to fix the problem, but it will still crash the X server if some other application uses a pBuffer while it is running. I’ve also found that sometimes an X-server crash will occur when quitting the application rather than when it’s starting up.

Does anybody have any ideas for working around this problem. I’ve tried a lot of different options in my application, and nothing seems to help.

My sample application can be found at: http://www.geocities.com/aubrey_holland/pbuffertest.C


[This message has been edited by aub (edited 07-18-2002).]

I tested the app and it makes the whole system go down here. My guess is that it is a driver bug but the example is mixing GLX 1.3 and the SGIX_fbconfig extension. No double buffer but glutSwapBuffers is called.

Here is the only documentation for SGIX_fbconfig that I know of http://techpubs.sgi.com/library/tpl/cgi-…_html/ch06.html
You should also send the app to nvidia.

I’ve filed a couple of bugs about this with NVidia already and gotten no response. I think the app is OK because it works just fine under more normal circumstances (less textures), and because I’ve tried changing it in every way that I know of to work around the problem. Just wondering if anybody else was suffering from it or had a workaround. Thanks! It’s good to know that it’s not just me having this problem.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.