Particle Engine

I have looked at the NeHe particle engine, and then convertd it into GLUT form. Now, it works, hoever, the black bit of each particle covers up whats behind, is there any way to get rid of the black are of the texture of the particle quickly and easily?

Bah, dont worry, I’ve figured it out, but Ive come up with nother problem, I cant set the alpha values, its always the same, no matter what I put into glColor4f, so this causes my particles instead of fadint, to simply disappear instantly when they reach the end of their life. Can anyone suggest something?

You have to check alpha blending, make sure its enable.

There may be another reason - your 3D accelerator doesn’t support SRC alpha blending.

Geforce256 doesnt support SRC blending? I dun think so…