OpenGL + Voodoo5 + RH7.2 = :( , messed up display

I have a voodoo5 5500 and rh7.2, and all OpenGL stuff runs, but its display is totally messed up.
The entire game screen seems to be stretching from the bottom left corner of my screen.

Having this issue with Tribes2 and to verify that it is not the game itself, tried tuxracer and the same issue happens.

( also has someone who is having the same issue with Quake 3.)

Any ideas?

(Running Xfree86 4.1 - default with rh7.2)

Well, I have a Voodoo3/rh7.2 and if you run the cube GL demo, you get no vertical lines on the box.

Tuxracer crashes the session.

The gears demo works fine though.


I had the same problem on Redhat 7.2 with a Voodoo 5 card. To fix the problem, I downloaded several glide files from

The files I downloaded are:



I think the only one you really need is the first one. I got the rest to help me mess around with the newest version of Mesa 4.0.

Also, I had to force the rpm install on the main rpm. So use the --force option. It conflicted with some X11 libs while trying a normal rpm install.

After installing these, tux and the other GL worked good.

Good luck to you! Hope this helps.


Actually, I had the exact same problem with you and had the exact same hardware and software.

As for Zandor’s suggestion of downloading those libraries and installing with force, do not do it. I tried it at first and was happy when gears looked good, but then glxinfo revealed that it was not using hardware acceleration.

I just managed to fix the problem on my systme, but I’m not exactly sure how I fixed it. I know I went to the page and installed the headers that were there. I got every file from there that I was missing. I installed stuff, and then downloaded mesa and did the build after I did all that stuff. Then I typed ‘ldconfig’ and everything was great. I’m not sure what it was linking up properly, but after much playing around and then typing that something must’ve clicked.

And I’ll say again, do not try and go to rpmfind and get those rpms and install with force. I did the same thing and it was a huge mistake, I had to reinstall all the original libs which was aggrivating as I wasn’t entirely sure which they were. Since we’re using the same hardware and software and have the same problem, I can assume that our solution should be similar.

Just out of curiosity, does glxinfo report for you that you’re using a Voodoo 4?

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.