OpenGL program on win 98 uses 100% CPU


I have an OpenGL program that render jpg images with zoom and alpha blend effects in full screen mode.

This program works perfectly fine on Win 2000/XP with about 12-15% CPU utilization. But the same program takes 100% CPU on Windows 98 and the rendering is way too slow. I can not even see the image movement when it is zooming. The hardware configuration is same as win2k (P4/1GB)

Note: The program renders images at the rate of 25 fps

Can any one just tell me if I have to code anything specific to windows 98?

I use following pixel description in my code:

static	PIXELFORMATDESCRIPTOR pfd=				// pfd Tells Windows How We Want Things To Be
	sizeof(PIXELFORMATDESCRIPTOR),				// Size Of This Pixel Format Descriptor
	1,											// Version Number
	PFD_DRAW_TO_WINDOW |						// Format Must Support Window
	PFD_SUPPORT_OPENGL |						// Format Must Support OpenGL
	PFD_DOUBLEBUFFER,							// Must Support Double Buffering
	PFD_TYPE_RGBA,								// Request An RGBA Format
	24,										// Select Our Color Depth
	0, 0, 0, 0, 0, 0,							// Color Bits Ignored
	0,											// No Alpha Buffer
	0,											// Shift Bit Ignored
	0,											// No Accumulation Buffer
	0, 0, 0, 0,									// Accumulation Bits Ignored
	16,											// 16Bit Z-Buffer (Depth Buffer)  
	0,											// No Stencil Buffer
	0,											// No Auxiliary Buffer
	PFD_MAIN_PLANE,								// Main Drawing Layer
	0,											// Reserved
	0, 0, 0										// Layer Masks Ignored

Thank you,

Wow, it really looks like you are running OpenGL in software with you win98 box…

What says GLinfo about your renderer ? If you see “Microsoft generic” somewhere then you need to fix your OpenGL install.
Tried updating graphic drivers ?

EDIT: maybe it is just your pixel format that is too strict. more standard value would be 24 bit color (+8bit pad or alpha), 24 bit zbuffer (+8bit pad or 8bit stencil).

Maybe even 16bit color/16bit zbuffer.


Thanks for the information.

I ran OpenGLInfo utility on Win 98 machine and found that it has following info:

vendor : Microsoft
Renderer : GDI generic
OpenGL version : 1.1

I also tried to use the Pixel descriptor parameters as you mentioned, but it did not help.

Is there anything else that I can do to solve this issue?


This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.