OpenGL games not running

I have tried for several weeks to run some of the OpenGL based games included with Linux and have not been able to. Basically I get this error every time I try to run them: Xlib: extension “GLX” missing on display 0:0. I have used both the NVIDIA drivers and MESA drivers. With the MESA drivers I can run the demos perfectly but the games themselves (Tuxracer, Chromium, etc) run so slow they are unplayable. Now I will list what my setup is and basically what I have do so far:

  1. Mandrake 8.0 Kernel 2.4.3
  2. TNT 2 Ultra

I have tried the following:

  1. Installed both the RPM packages and also compiled and installed the source files of the NVIDIA drivers. Both show they are installed ok.
  2. Modified any or all XF86 files and made the changes shown in the NVIDIA readme file i.e. the GLX entry in the modules section.
  3. Modified the GLX Config file for some of the AGP and DMA options.
  4. Reformatted and reinstalled Linux several times.

Am I missing something? Does GLX have to be capital or spelled a certain way? Any help appreciated.

I think you just forget some steps.
Have you compiled the Nvidia kernel drivers and the glx ones ?
find them and compile first the kernel by make install then the glx ones by the same command.
then modify the xf86-4config file in /etc/x11
add load “glx” under the other command line load “vbe” or smthin’ like that. then replace driver= “nv” by driver= “nvidia” some lines following the precedent.
then you just have to restart x

good luck and sorry for the unprecisions, i am in school.

Yes I did that. That is what I had tried when the RPM install did not work. Like I said when I compiled the binaries it showed that they were install fine. I did add the “glx” setting too. Any other ideas? I will try or am trying to install the latest version of XFree86 and see if that helps.

it could be another problem i think i have already met.

Have you tried to compile an opengl programm with the -lglut -lGLU -lGL parameters ?
Does it work ?
if not, just try -L/usr/… for the 3 libraries. Not all the library paths could be not recognize.

Thanks for your help. I am not sure how exactly I would compile a Opengl program so you might need to give me a step-by-step explanation. What do I do with the -L/usr/
command? Just run that from a prompt and see what it brings up?

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.