OpenGL for XP x64

I am using Visual Studio 2005 and Windows XP x64. I am having trouble installing OpenGL due to x64. Does anybody know a work around for this?

Just curious, but how do you expect to get any help when you don’t even say what’s wrong? Saying “having trouble” does not provide any information what so ever about what’s wrong.

I guess that was kind of vauge. I went to
and downloaded the openGl sdk. when I try to install it I get this error message-
"The program or feature “??\C:\DOCUME~1|ADMINI~\LOCALS~1\TEMP~EXB0000\DISK1\SETUP.EXE” cannot start or run due to incompatibility with 64-bit versions of Windows. Please contact the software vender to ask if a 64-bit windows compatible version is available.

when I try to compile I get a linker error
fatal error C1083: Cannot open include file: ‘GL/glut.h’: No such file or directory

i dont have the file GL/glut.h on my system and I probably need it. It comes in the sdk I think. I am hopeing if I can get this file and any others that come in the SDK I might be able to bypass the problem. It also just occured to me that it might use a 16 bit installer which cant be emulated by wow64

thank you for the fast reply

There is not need to install a OpenGL SDK to be able to run OpenGL programs, not even on Windows XP x64, and by the looks of your last message, you just want to compile a program with GLUT.

I’ve never seen a glut.dll compiled for Windows x64, but if you want to try to compile it yourself, the source for glut and many more stuff can be found here:

But anyway, is telling me/us that GLUT is no longer maintained, so you should look for a newer OpenGL Framework.

This SGI SDK you were trying to download is a 10 year old distrubution and only of historical interest.

Your problem is with GLUT and win64 platform. To be honest, I have no idea if GLUT supports win64 (I suggest you have a look at ). If you don’t find a win64 version, you will have to compile it for win32.

To replace glut, try freeglut or openglut.

Never tried OpenGLUT, but FreeGLUT is jim-dandy.

i compiled glut for x64 windows from its source without problems. so download the sources and compile them. but i also think using FreeGLUT is a better idea.

I really got owned on this one…
I compile the whole thing, I put the files where they normally wanna be and everything seems to be running just fine…
Then i try to compile one of my progs that I made back on my notebook and… bam!

fatal error C1083: Cannot open include file: ‘GL/glut.h’: No such file or directory

Managed to solve this one adding some absolute paths in the compile path list, because apparently, the relative ones aren’t working properly (no idea why…), but now, I’m stuck on this:

error LNK2019: unresolved external symbol _glutSwapBuffers@0 referenced in function “public: void __thiscall Scene::Display(void)” (?Display@Scene@@QAEXXZ) rp.obj

I imagine that’s because my VS doesn’t want to see the glut32.dll, but I copied it to the system dir where other dlls are (in my case c:\WINDOWS\system32 and c:\WINDOWS\SysWow64). I also made sure both of these folders are in the VS include path.

Any clues what to do next? I really wanna hang myself right now…


The link error means the linker cannot find the function - and functions are stored in the *.lib siles (yeah, I absolutely dislike this separation!). Do you have the corresponding glut lib file in the library path?

Aha, and I thought I was past this…

Thanks for pointing to the cause of this error. I dug a bit deeper and after moving the path in the linking directories all the way up to the first position, There seems to be a progress… (I don’t have a clue as to why at the end of the list, the dir wasn’t visible for the VS, no…)
I got this:
fatal error LNK1112: module machine type ‘x64’ conflicts with target machine type ‘X86’ msvcprtd.lib
Solved this, I’m not pretty much sure how… Guess the problem won’t be in GLUT any longer, so I’ll stop spamming this feed with it, I guess. The thing was that VS didn’t pretty much offer me anything except a win32 target platform, so I had to add it with some obscure procedure…
I only have to convince my VS now that I wanna debug the 64 version, it’s not able to find it, apparently.

Thanks for your help guys!
You gave me hope in finishing this blasted project again.

Uh, I guess I’m going to have to whine again…

As I mentioned before, I somewhat played with the paths to include libraries to shake off the
error LNK2019: unresolved external symbol glutCreateWindow referenced in function main
Well, I actually tried to compile my real project. First of all, I got the 400errors in gl.h from the neighbor topic. I included windows.h, thinking that glut may not be perfect…
Well, it worked, but now I’m getting plenty of these
error LNK2019: unresolved external symbol glutCreateWindow referenced in function main
on glut functions, not knowing where’s the actual problem…
What I did was:
In the general settings, I checked the path to the correct lib and include directories.
In project settings, I added the correct lib/glut directory to Additional Library Directories.
I also specified the glut32.lib file in Additional Dependencies.

I still eat my 24LNK2019 - I’m toast. Ideas?


This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.