OpenGL extensions and QuakeIII

Hello everyone!

I have compile QuakeIII engine with a Depth of field effect inside and everything is working great…but…

But i have a problem with the extension string who is different in my QuakeIII compilation and in original QuakeIII!!! ARB texture float are missing for example but in other program i can use it. And in QIII if I force using float texture, all is working great.

But why my OpenGL string is different? I don’t undertand…
Someone has an idea?

If I remember correctly, there was problem with fixed length of the buffer used to work with extension string in the Quake. To combat this problem, the nVidia drivers have special settings applied if quake3.exe is running. That setting limits length of the extension string returned to that application.

Hmm thanks, I’ve seen this functionnality in nvidia vidéo driver. I haven’t enable it and i don’t use the QuakeIII profile.
The problem exist also with a 1900XT ati card(i have a nv7900GT). With the same card, the original quake3.exe don’t have this problem…

really strange…

just for info, some OLD screen with Depth of field :

As Komat say it, nvidia driver have special setting for Quake3 but i have disabled this feature and the probleme was still there.

I have named my program quake3DOF.exe instead of quake3.exe and the probleme disapeard 8-() !!!

It seem that driver always use the optimisation even if you disable the feature…

However now there is no problem!!!
thanks Komat for your help!

Yeah, sometimes it is even worse, a simple exe name change does not work (leaked Doom3 Alpha needs old drivers else no display :rolleyes: )

Yeah! you’re right! I remember…

<little voice> I have really enjoy play this leak before a long time final game release</little voice>

PS : finally i’ve bought this game! I’m a big fan of Id, particulary JC’s engine…

Originally posted by hseb:
<little voice> I have really enjoy play this leak before a long time final game release</little voice>
I bought the game too, slightly disappointed to see that unlike the alpha, not all lights casted shadows, and self-shadowing was disabled on most monsters…

Yeah! I agree!

selfshadow is a good thing! Drop them was, for me, a bad trick…

but there is a mod to disable noSelfShadow…

I’ve download QuakeIII. But my compiler can’t compile it. Something missing in my libraries.
What specifically so I can through to compile it.
My Computer had:
-VS .NET 2003
-CG Toolkit

Thanx for helping me.

have u look at ur compiler manual :confused:

quake 3 compilation made easy (with mingw and msys) :

I had 0 problem with that. Just follow README steps.