OpenGL Error With glDrawElements


The Error is that I can not run a application using glDrawElements using my opengl base code (which is quite closely derived from the NeHe base code), This code compiles fine. But when running the app, there is a error message displayed,

The “/P” command-line switch must be followed by a PID (Process ID).

A nice error that I have had before, the last time it was a Direct X8 error, and a installation of the latest graphics card driver’s fixed it. (I have a Voodoo 5 5500).

I do realise that the glDrawElements function is for the OpenGL 1.1 and greater implementations, so I presume that my lib’s are out of date. I also tried the same code but instead of using my OpenGL base code I used GLut and everything ran fine! Form this I presume that my OpenGL lib’s and include files are of OpenGL version 1, so my question is were can I download either the OpenGL Version 1.1 or 1.2 sdk files for Windows and Visual C++ 6

Thanks in advance 3DG

If your library/header files was of an older version, your code wouldn’t compile at all, which your code obviously does. Anyways, I have not heard of that problem before, so I can’t help you, sorry.

Yes sorry I am being stupid. Obviously I would get a compilation error if the problem was my lib and include’s, it is strange. I can run the exact same code but with a few changes and using the glArrayElements and all works fine. But again trying to use a OpenGL 1.1 function glDrawArrays gives a error.

Any thoughts would be very helpful.

Again Thanks In Advance 3DG