NVidia Quadro AA Lines bug!?


I have found very strange issue when I try to render AA lines on Quadro card. Here is sample code:



for (int i=0; i<points.size(); i++)

Result is ~10% transparent fat (15pixels) AA lines. Im expecting normal fat AA lines. Can somebody else with Quadro confirm this.
On other “gamers” NV cards this code works correctly.

Tested on:
HP 8710w (NVidia Quadro 1600M), XP SP2, FW 169.21.


tested on Quadro 4500, XP SP2, NV 165.42
Works fine. 100% white, fat lines.
Maybe only Quadros based on G80 chips have problem.

It works corectly on Quadro 2500M too. You are right… Looks like AA lines is broken on G80 based Quadros.

Anyone from NVidia… Can you fix this?

You should send them the sample app.

Works correctly on my HP 8710w.

Tested on:
HP 8710w (NVidia Quadro FX 1600M), Ubuntu 7.10 (Gutsy Gibbon), FW 169.09


>>Result is ~10% transparent fat (15pixels) AA lines.<<

FWIW, glLineWidth(15.0f) shouldn’t be a supported line width on your implementation. You need to check the implementation dependent smooth line min, max and granularity values before setting arbitrary wide widths.
Some OpenGL implementations support only the minimum spec requirement which is 1.0 wide AA lines.
On NVIDIA smooth lines can be 0.5 to 10.0 wide with 0.125 granularity. Means your lines rendered 10 pixels wide, not 15. The transparency thing sounds wrong though.

Works on my Quadro FX 4600 (G80GL) in either width producing 10 pixels wide white AA lines.

Yes… you are right… I didnt check limits… Anyway, transparency is bug.

Seems it is a problem only on G80 based Quadros.

>>Seems it is a problem only on G80 based Quadros<<

But it worked for NiCo on a similar system and on my desktop G80GL system.
Could be just your driver on your laptop. How did you get that on there? It’s not supporting Quadro according to the download site.

You can give these Quadro WHQL drivers (169.61) a try.


Nico tried on Ubuntu… Im on WinXP…
Now Im using 171.16 and still have issue. :frowning:

OK… I fixed this… problem was wrong value in registry.


Change value OGL_AALineGamma to 0x10 (16)

To get proper {YOUR_GUID} value check key

Seems that driver cause this problem. Im using moded drivers from http://www.laptopvideo2go.com and I found that .inf file have incorect AALineGamma value (0x23).

I’m not sure that’s a bug. I can change this setting in the nvidia control panel. If I do, I get the same result as in your original post.


Dunno… Anyway on default value 0x23 AA lines doesnt render correctly.
You are right. It’s not driver bug… it’s a driver installer bug.