NVidia drivers are out!

Anyone tried them out yet?


I will give a try tonight…

I’ve tried 'em (Diamond Viper V770 TNT2, AMD Athlon 700Mhz, AMD-751 Irongate). With a little patience, got them configed and working well. Windowed performance is still crap (but i think it may be that i still have old libGL’s in /usr/lib) But fullscreen performance is blistering away. I was getting anywhere from 60-80 FPS in Quake3 arena (16-bit color, lightmaps, high detail geometry, 16-bit textures), where I only get about 50-60 in Windows. These drivers are BETA and are beating my Windows performance. I like this. But I would like even more to see some source code. The image quality isn’t ICD quality, but it’s still good. And these drivers are still new. If nvidia decides to keep working on these drivers, then it won’t be long until we see them smash the Windows drivers into the ground.

Yup. My presumptions on windowed OpenGL apps was correct. Replaced my old libGL.so’s in /usr/lib with nVidia’s libGL.so. BANG! Fast as hell windowed performance. Still beating Windows. This is too cool.

I can’t compile under linux 2.3.99-pre-3 … A lots af error and similar things … Anyone how can help ??

You have to use a 2.2 kernel. just load one into, say, /usr/src/linux-2.2.13 (or whatever version) and edit the install.sh script where it says
make | | {
make SYSINCLUDE=/usr/src/linux-2.2.whatever | | {

and then run ./install.sh fromt the direcotry

I’ve a problem to execute programs, which require glX. I’ve already installed all XFree4.0 modules, but it doesn’t run.


here’s a silly question: now that i have Nvidia’s OpenGL driver for my tnt2u card, instead of Mesa/ GLX, how do i complie opengl software like FlightGear? Can I use Mesa components for compiling and the OpenGL driver will be nice and run them?

I have exactly the same question as above. Now I can run acclerated OpenGL apps, how do I role my own.

I tested the Xfree4.0 and Nvidia driver combo.

First I decided to compile Xfree4.0 on my own because the Xfree4.0 rpms I have were using an alternate path (X11R6.4) instead of current on (X11R6), this is only for convenience. I also change the makefile (I always do) to use pentium pro optimizations (PII/PIII/celeron) (mcpu=pentiumpro -march=pentiumpro), this way the code is normaly a little bit faster but is unusable on other architectures.

nVidia install was easy (like an install on linux could be).

The worst part was configuring Xfree, keep your old XF86config file under hands…

For convienience I linked MesaGL library to the nVidia GL library. These way you could use Mesa linked program without any problem. If you do not want to rebuild your makefile, you should probably link MesaGL.a to GL.a to avoid problems when compiling (I didn’t try but this seems recommended). On the other way you can change the makefile by replacing “-lMesaGL” by “-lGL” and probably add “-L<X11 lib path>” in the link part of the makefile.
You can use the Mesa package to have the gl.h ang glu.h for compiling and development.

On the test part:

First, I have no problem now with vertex arrays, they do not crash at all. But I noticed a little problem: every 1 second, there was a disk access (under X and with nVidia module only). The 1 second interval told me it was probably a swap access. It was annoying because the screen freeze during the swap (and I have SCSI!). In my bios setup, the AGP aperture size was 128Mo (I have 128Mo), I reduce the aperture to 64 and the swap was gone…

On the bad side: there is only a few (no… a couple of) extensions supported (no compiled vertex array!). So they are really beta drivers…

Anyway, I can now develop GL apps under Linux without major pain…

[This message has been edited by MC (edited 05-09-2000).]

I have a card based on the Riva 128 chipset. Apparently the new NVidia drivers do not support this older chipset, but they make a confusing statement in their FAQ that “The NVIDIA NV1 and RIVA 128/128ZX chips are supported in the base XFree86 4.0 install and are not supported by this driver set.” From what I can tell, this support is for 2D acceleration only. Am I stuck without 3D acceleration?

I have a riva128 too, and for what I understood from the docs, is that the driver in 4.0 is the same as 3.3.x. So basically you would have 3d acceleration. I haven’t tried it though…


This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.