Nividia GeForce GTX 1060 with driver 391.01 doesn't give OpenGL past 1.1?

#1

Hello,
I have an Nvidia GTX 1060 and I’ve updated my drivers to the latest version they offer (as of this post), but I cannot seem to get an OpenGL version other than 1.1. I don’t know what I’m doing wrong, as I’m using the “GeForce Experience” application from the Nvidia website to update my drivers and the version number matches the one on their website. To view the version of OpenGL, i am using OpenGL Extensions viewer 5.0.

I am aware that OpenGL is not a software, but rather a specification that drivers that ‘support’ it follow, but if updating drivers doesn’t work, do I have any other options?

A picture of my predicament:
https://photos.app.goo.gl/TX2tFqxc5vNm9zgn2

Any help will be appreciated!

#2

Did you try a clean install of the NVidia driver (it’s a checkbox in the installer IIRC)?

Also, you might try:

[ul]
[li]OpenGL Hardware Capability Viewer[/li][li]GPU-Z[/li][li]Vulkan Hardware Capability Viewer[/li][/ul]

#3

@Dark Photon:
Thanks!
I feel like i should have tried that.

#4

No problem! Like you probably, I virtually never do a clean install, so it’s easy to forget about.

#5

[QUOTE=Shabib;1290702]Hello,
I have an Nvidia GTX 1060 and I’ve updated my drivers to the latest version they offer (as of this post), but I cannot seem to get an OpenGL version other than 1.1. I don’t know what I’m doing wrong, as I’m using the “GeForce Experience” application from the Nvidia website to update my drivers and the version number matches the one on their website. To view the version of OpenGL, i am using OpenGL Extensions viewer 5.0.

I am aware that OpenGL is not a software, but rather a specification that drivers that ‘support’ it follow, but if updating drivers doesn’t work, do I have any other options?

A picture of my predicament:
https://photos.app.goo.gl/TX2tFqxc5vNm9zgn2

Any help will be appreciated![/QUOTE]

Hello, Shabib.

I have exactly the same problem, with the same videocard. Were you able to fix it somehow?

Thank you!

#6

The OP gave the impression that a “clean install” fixed it for him. As mentioned, it’s a checkbox in the GUI that pops up when you install the driver.

Download from here: https://www.nvidia.com/Download/index.aspx