New NVIDIA drivers screwed my opengl app!

well i just got the new 56.64 drivers for my nvidia gefore ti4200, and now the opengl apps that i made crash on startup. my old drivers were the 53.03 … i am also using the free borland 5.5 compiler … i have no idea why this is happening, the code compiles and links perfectly (like it always did) but as soon as i got the new drivers my apps crash … do i need to get new opengl header files? any help appreciated!

Have you tried stepping through the OpenGL initialization portion(s) of your source code with a debugger to verify the context is being created with no problems? A debugger “might” also help you identify where in the code it is crashing.

Hope it helps. Sorry if you’ve already tried this.

this might sound elementary [but i must ask] - did you uninstall 53.03 before installing 56.64?

-=[ regards ]=-

You should not need to uninstall previous drivers for new ones to work.

You could try reverting back to the earlier drivers that worked for you.

Not all hardware is the same and I’ve had problems where new drivers from nvidia broke hardware, especially early revs of their cards.

Originally posted by dorbie:
You should not need to uninstall previous drivers for new ones to work.

nvidia’s site suggest that you uninstall prior drivers BEFORE installing new ones.

-=[ regards ]=-

Does it happen with any other apps/games?

No and that’s the thing that’s wierd … well i narrowed it down to either my font or texture routines … when i run just a basic pong game with no text or textures it will run, i’ll do a little more experimenting and see if i can get it down to a specific command.

I’m curious, where on NVIDIA’s site does it say to uninstall earlier versions of their drivers?

Not saying they don’t I’ve never seen this and never done it.

Here are instalations hints for NVIDIA display drivers
Best regards,

mproso: thanks.