Microsoft C++ and OpenGL

After installing Microsoft Visual C++ 6.0 my OpenGL drivers stopped responding. Any call to OpenGL functions results in an error. Both my code (which worked before) and commercial applications (games ect.) end up with a blank screen. Can it be fixed? Only uninstalling VC++ seems to help, but that isn’t any solution.

Try the “user help” board.

You have a unique machine then.

What’s your OS?

Originally posted by jwatte:
Try the “user help” board.

Damn fine idea…

But heck, the question has VC++ (which you use for coding) and Opengl - and I guess once you get past installation of VC++ you’re advanced.

(Another idea would be to try reinstalling/updating your video card drivers - but I liked johns better)

So, i guess you just have no idea what’s wrong. Thanks for nothing anyway.

My pleasure … and you still didnt mention your OS.

(re)install the latest drivers for your video card and get the latest service pack for dev studio 6…

Microsoft quality ei?
I have never had problems with EEVC++ 6.0
and OpenGL, but i think that DirectX has
screwed up my AGP-port, since when i have
my ATI Radeon plugged in PCI-card´s can stopp
functioning mysteriously (and you cant
install or re-install any).

Wilk their are some drivers out there that prevent debugging (ASUS comes to mind).

Since when you install VC++ it registers itself as a debugger, well who knows, maybe your drivers dont even like that.

Btw, you forgot to add some valueable info to your post like: what OS, what card, what kind of drivers…

“It dont work, fix it for me” kind of questions arent very welcome here.

[This message has been edited by HS (edited 04-24-2003).]

Have you tried reinstalling your drivers or even installing newer ones if they exist? If that does not help contact the people who made your video card (ie NVIDIA, ATI, MATROX, etc) and tell them about it. Maybe they know of this problem already and can give you an easy fix.


Here it goes then:
Asus GeForce 2 GTS
NVidia drivers 41.09
DX 9.0

I usually fix my problems myself, but this time i’m out of ideas. Reinstalling anything doesn’t help at all. These problems started after uninstalling VC+ 5.0 and installing 6.0. Getting back to 5.0 now doesn’t change anything.

Sorry for not giving enough details, i thought that maybe you’ve encoutered this problem before and will be able to help straight away. That’s why i posted here, to ‘advanced’ section.

Just what makes you think that openGL drivers are not working? Or did you just throw that in since this is a openGL forums?

Installing VC++ has nothing to do with it, it don’t touch ANY opengl (or DX) drivers at all.

Check your event log, for possible errors/warnings, also check device manager for any “!” errors.

P.S, I got same setup, works no probs. Oh, make sure you have SP3 for win2k.

He said he installed VC and anything using GL wouldnt run, and the only solution was to uninstall VC.

The story has changed now.
Im sure you left out other details such as what other changes you made to your system.

In any case, VC itself is a peice of software that rests dormant on your HDD, and also puts a zillion registry entries, and this in no way interfers with any other thing, and will not cause GL errors.

V-Man…please stop wasting your time and mine…