Memory Leck On Win 2K

every time i run an opengl application ( not important what one ) it takes me away bout 20mb ram… no problem so far… but when i close the program it just gives 16mb ram free again, so i’m loosing every time i run an opengl application 4mb ( 3.8 for more info )

i thought its my app… but it isnt… ( even q3 looses this damn 3.8… )

i thought it is the driver… but not important wich one i install ( official det3 or even 11.01… ), no difference…

i thought it whas some setting in the driver, so i dis/enabled everything i got there in the driver settings… no difference

so, what is left is the win2k, cause on win98 i hadn’t the problem…

its terrible somehow to work with it… cause when i code, i recompile and start my program bout every minute… and even if i have 1024mb free virtual ram… when i have filled up my real ram ( 128mb, 65 filled after booting… ), i have to reboot cause nothing works anymore…

you can calculate yourself how much i have to reboot…

i’m happy for every idea to stopp the bug…

bear in mind, that when your app runs and
accesses filesystem, the system will increase the file cache which isnt released when your app terminates. this memory is not lost; the system will reclaim it later if more physical memory is needed for apps. this is not a leak, just a normal behavior of the virtual memory manager…

i LOOOSE the mem, it dont come back after, and at the moment i have “filled” 128mb ram ( with taskmanager visible… ), my hd is running fulltime cause it does not have any free ram anymore… AND I SAID EVERY OPENGLPROGRAM, means i can use glut and just init it and close it and i loosed 3.8mb WICH I NEVER GET BACK!.. i can do a simple Win32 App with a wglMakeCurrent and this… and i loose 3.8mb


and not just my app’s, as described… its just the most stressing there cause while coding i start my app very, very often…

oops, didnt read till the end of your message; so basically, after running
your app many times in a row, the system
starts running very low on virtual mem?
maybe opengl/driver is not cleaning
up properly…

yeah, but its EVERY driver! ( i tried bout 10 yet… officials leaked and betas, whatever… dont work with any… every time the same problems… )

This does sound strange. If I am reading the first post right, then you are saying if you run your program enough, it will fill all 1024MB of your swap file? If so, thats strange…

Did you run a virus check? In the Task Manager, on the “Performance” tab does your thread count or process count increase after every time you run the program? On the “Processes” tab, do you see the same exe listed 50 times? The symptoms are really indicitive of another process spawning in the background.

If no, look again in the “Processes” tab and see if any process has an incredibly high “Mem Usage”.

just one time… should i post some pics? somehow bad, cause to do so, i have to go near a crash

no, cronos… it does not filll the virtual mem, just the real one ( 128mb ) and then win2k gets really instable and i normaly have to reboot…

what you mean, no the count of prozesses/threads whatever is always the same… when i start, inc one, when i finish it, dec one… when i start inc one when i finish dec one… and just one time the exe

its a free installed win2k and i didnt did anything but starting an opengl app… i dont think its a virus cause since i have win2k i had several reinstalls and always the same happens…

except if you say win2k is a virus, then yes, i have one

hm its really weird… i cant see it, cause i can do a program wich dont use opengl wich allocates thousands of giga ram every second without deleting it and after closing the app it all gets free… ( 3dsmax, for example, when i dont have opengl enabled )… even when it crashes

just when i enable and disable opengl it eats up this little chunk ( not so little… sometimes i have to reeboot every 15minutes… when i have stress with registercombiners and i dont know why it looks like it has to i start my program bout 5 times a minute… and this no good… )

its ****ing hell to work like that …

hm i can try a new thing, perhaps it works even like this:

EnableGL( ){ … wglMakeCurrent… etc … }
DisableGL( ){ … wglMakeCurrent(0,0) … etc … }

and then doing it in a loop… 5 times… should then have a memoryleck of 5*3.8 ~= 20 mb…

Have you tried installing Win2K Service Pack 1?

yes, no difference…

First of all, how long has this problem been going on? Is it recent?

You said that you were using a “free installed win2K”. Did you mean ‘fresh’, as in a recent reinstall, or ‘free’, as in pirated? If the latter, there may be a virus in the copy of Win2K you have (some pirates have been known to do that).

Has anyone else using Win2K run into this problem? I’m using Win98, so I can’t tell.

are you sure the programs have closed fully (look in task manager) sometimes i have this problem with win2000. the app closes, its not visable on the taskbar yet it hasnt closed fully. i then have to kill the process myself. also perhaps you need to update your motherboards drivers/bios. eg via boards have had problems in the past with agp cards

Originally posted by Korval:
Has anyone else using Win2K run into this problem?

Nope, I’ve been running Win2K since the day it came out, and its been rock solid. I havent reinstalled it once, and in that whole time I’ve only been able to crash the OS twice. I’ve NEVER had to reboot midday for any reason other than installing software. I do shut it off each night, so its not like its been up for a year straight, but still…thats not too shabby.

Anyway, I have a Geforce2 GTS 64MB with the 6.18 drivers, and not a single problem. I just ran my own openGL app 15 times in a row, and each time I closed the app, my memory went back to within 1/2 MB of the what it was before the first time I ran it.

hm… damn… i try this 6.18, too but i somehow dont think it is this…

result later…

My experience is that the 6.31 drivers are the only released drivers that seem to be stable under W2K. Don’t know about the 10.x drivers since I’ve not tried them out.

( yes i backup 6.31 (or was it 6.34) very stable the latest official (6.50) are crap with win2000 crash,crash,crash . have you tryed paul nettles memory manager pogram (ive found it to be excellant, bar one error) it should track down any leaks in your program.

cool, where do i get paul whatevers memory manager?

Originally posted by davepermen:
cool, where do i get paul whatevers memory manager?

Just to be clear, its not like a windows memory manager, so it wont help your problem. What it is is code that you compile into your projects. It basically replaces new and delete with its own version. The advantages are that it can do a lot of cool things, like track each allocation and give you a list of which ones were never released (ie: leaks). It can do things like detect when you go beyond the bounds of an array, or when you allocate memory that you never use (like if you allocate a 1MB block, and only use 1/2 MB, it can detect that and alert you that you arent using memory efficiently).

That being said, you can get it from here:

The link is at the bottom of the article (but before the reader comments).

As nice as that window manager might be, if it is happening on all his OpenGL programs, even commercially avaliable ones, then I doubt it will be helpful.

I can’t see how it could be anything other than either his drivers or an insidious virus.

a virus it cant be somehow cause i had several times completely removed everything from my pc… with formatc… between i for example played with linux around, with BeOS and even reinstalled win98… ( win98 dont have lecks… but it likes to crash… one time win2k…never go back )

so… the driver… letz test my newest driver downloads if they have the leck, too… but its just somehow on win2k… thats what iritates me really… letz see…

Viruses can hide themselves in the MBR, and format C: wont get rid of those nasty ones. I cant remember how to clean those. Is it something like “sys /MBR” ?