Intel 945GM OpenGL drivers not working

I’ve bumped into a bit of a problem with my computer, a thinkpad z61t with an Intel chipset.
I did a fresh reinstall of Vista+SP1 32-bit Business version, and now the OpenGL drivers are gone. I then tried to install the display drivers from the IBM site with no luck. Then i uninstalled, and went on to install the ones from the intel site. Without any luck from there either.
Figuring that it worked on my previous windows installation, i did a re-install of Vista. And lo and behold! OpenGL drivers were found when it first logged into Vista, which were identified as the generic one that follows with Windows. Thinking that my problem was solved, I installed the driver controller from Intel and did a reboot and then the driver was gone.

Driver version that i have is:
Windows Vista Business 32-bit.

I hope that someone here might be able to help me with the issue, so i can start using Livestation again.

First you should complain loudly to IBM and Intel.

Not to worry. I am in the process of getting support via Intel, who tried to say “from the sound of your problem, try”, which is a bunch of bullcrap that the graphics vendor is trying to relay THEIR bad driver support onto a standard that can be implemented off the shelft. Which i by the way have mentioned to them in an e-mail reply.

I did not consider writing to IBM, and will actually do that now, thanks for reminding.

and a big thanks to ZbuffeR for leading me into the right direction.
I went to the IBM site to start a thread regarding the issue, but figured i’d do a search first. Searching led me to this thread:…& and helped me solved the issue.
The following is what i did:

First i downloaded the appropriate driver from the IBM site, unpacked it, and noted the location.
Then i went to device manager and uninstalled my display drivers from the display adapter fold-out-menu.
Rebooted the computer
Once logged into Windows again, I went back into display adapter and right clicked on my “unknown VGA controller”, installed the display driver manually pointing to the location where the previously downloaded driver was unpacked.
Reeboted the computer once the driver was installed, and then fired up Livestation (the program using OpenGL) and it worked.

At first it does not recognize an OpenGL driver, but once the program is running it identifies the correct one.

I imagine that downloading from the Intel site, manually unpacking with WinRAR will yield the same result.

Glad it worked.
Laptop drivers are often a hassle.

I’m just curious, what the highest OpenGL version does the Intel 945GM support?
The API version (1.1, 2.0, 3.0, etc…), not the driver version.

I’m guessing maybe 1.4 or 1.5?

Does anyone know if Mesa OpenGL drivers ( ) can provide support to higher version OpenGL extensions?

Since the 945 is a DX9 part and supports SM 2.0 shaders, GL 2.1 should be supported.

On Linux, there is GL2 support via the Mesa drivers and it is hw accelerated or so I heard.
If you have Mesa for Windows, it is just a software renderer.

GL 2.1 is a lot more than just shaders.

The problematic features for i945 are multisample and occlusion query.

I just had a look at the Linux driver source.

According to that the 945 driver can do GL_ARB_multisample, but not occlusion queries. So the highest version you’ll get is OpenGL 1.4.

For OpenGL 2.1 you’d need at least a 965 (or a 946GZ).