How do I disable ALT + TAB in Win32?

I know the issue has been battered before, but no real solution was found.

With win2000 and the latest drivers from Nvidia for my Riva TNT2 card, the program reacts in the following way on ALT + TAB:

Computer reboots immideately.

This happens with other major games aswell (Tribes2), but not Quake3, because Mr Carmack disabled the ALT + TAB feature under fullscreen.

Now I need that feature aswell…

Any clues?

Ya hooooo!!! I disabled the screensaver with that function . Thanks for unintentionally helping me lpVoid .

i believe its your drivers sometimes the most recent ones aint the most stable. personally ive found 10.80 to be more stable than 11.x also 6.34 is far more stable than 6.50

my sarcasm filter isn’t loaded at the moment, so either…

glad I could help




No sarchasm here! I have been meaning to ask how to disable screensavers! I guess if you wait long enough though someone will ask the question for you .

10X (XX,Thanks) for the link ‘local void pointer’,
I have now implemented the Hooks and it works as assumed.

I don’t know if this makes it a window NT and windows2000 only application or if it can be run under win95/win98 aswell without recompiled binaries.

I threw in the win95/win98 version of block aswell to be sure.

Im atleast glad that I could help WhatEver aswell , although somewhat indirect.