Help: nvidia TNT2 M64 + Mandrake 7.2

Help: I’ve finally upgraded from Mandrake 7.1 to 7.2. (The problem with stable development platforms :wink: )

I had a V3 3000 but I was not happy with the performance (with UT) so I swapped it for a spare TNT2 M64 just to see, and downloaded the kernel-…src.rpm and the GLX packages.

To be on the save side I edited the kernel driver source according to the M64_USERS_README, and installed the packages, edited the XF86Config-4 file and X started perfectly. However…

Whenever I run an OpenGl program (eg gears), it runs for about one second, then locks up the entire system. (cannot even rlogin or telnet to the system to kill the program or the X server.)

Is this due to floating GL libs?
Or an incompatible libGLU?

As an aside, is it possible to use Mesa headers to compile .o’s that will link to the nvidia drivers?

Or would the SGI sample GL code be better.
And would the SGI sample GLU be a suitable replacement for the libGLU already on the system.

So many questions… Thanks for any help.


You can read the /var/log/XFree86.0.log file
for errors and versions of nvdriver and glx. I have MDK 7.2, kernel 2.4.1 and drivers version 0.9.6 and it work.

#less /var/log/XFree86.0.log
It all seems to be loading correctly…

BTW:I’ve discovered that XFdrake --expert is good for creating an initial XF86Config.

I’ve tried renaming some stray libGL’s etc.
now, gears just segfaults, instead of locking the system.
I seem to remember that mesa’s gears is still linked to libMesaGl, and I don’t have one of those any more… (and ldconfig has started complaining that it is no longer there.) Time to create some links, then suck it ans see.

Tony thanks for the heads up!


If you install driver in rpm format, it automagically rename mesa libraries. In my system there are three examples (gears, morph and reflect) and they running fast. The problem with ldconfig is not important if programs don’t links against the not present library.
Sorry for my english!

I think that the problem may be elsewhere.
In windows, getting this card to run on my MSI socket 7 motherboard requires some special bang up to date ALI agp drivers, otherwise if hangs the PC in very much the same way as it does on Linux.

oh well back to the 3dfx.


Tony, don’t worry about your English. Anyone who can use the word “automagically” without blushing need not worry. :wink:

If you think the problem is agp it is possible to disable it. In the screen section of XF86Config-4 set the option NvAGP to 0.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.