Help Compiling OpenGL Stuff

I downloaded and installed the Mesa libraries and the demos. Compiled, and the demos worked. Then I tried to get some game engines that work over OpenGL, including AllegroGL and SDL. However, none of them would compile any applicaitons. For some odd reason, I get an error about grBufferSwap() being referenced without being defined. I was told that this is a Glide command (which would make sense I guess as it doesn’t start with gl). I then downloaded SGI’s GLU and tried to compile it - I got the same error! What’s going wrong? Did I somehow get a faulty include file in there somewhere or something?

I suppose that you have a 3dfx card and this was detected by the makefile so it built Mesa on top of glide. For this to work must glide be installed but the errors says that you do not have it installed. You should be able to find a rpm here

GLU is a helper library sitting on top of OpenGL so it is not strange that you get the same error as with the other helper libraries. I think later versions of Mesa already has the SGI GLU library.

An OpenGL on top of glide is not your only option, it seems like the DRI project also has drivers. I assume that they are not depending on glide.

I actually have an nVidia card, with the OpenGL drivers they supply installed. Does this change anything?

Yes, that changes everything. If you installed Mesa after the nvidia drivers was some essential files from nvidia overwritten. New drivers are available so the easy solution is just to install them overwriting the files from Mesa. Run the glxinfo command for a check after the installation.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.