have anyone come across this problem when

wglGetProcAddress(“glSampleCourageARB”) return NULL value.


i did uses wglGetProcAddress(“wglGetExtensionString”) and the value returns do include “WGL_ARB_multisampling”)

So what’s wrong???

The hardware i’m using is Elsa Syn II

LOL check out your spelling:



ROFL!! sorry couldnt resist that. OpenGL doesnt like it when i try to give it more courage too. j/k!


[This message has been edited by SirKnight (edited 03-11-2002).]

Yes, sorry of that mistake.

But i did spell as glSampleCoverageARB
in my program.

Have you been able to load any other extensions? I say that because maybe your extension loading code is wack. On the main page a few days ago there was a news post about some functions this guy made that will load all extensions your card supports with one function call. Maybe you can try that and see what happens.


I think i have gone through that discussion. However i tried loading other extensions and it just work well. And When i downloaded a software fron nVidia, the software is not able to detect multisampling too.

i start to wonder is it due to the driver or the hardware???

Any comment?? Thank you

I’d guess it’s the driver. Try opening the driver file in a hex editor and see if you find a “glSampleCoverageARB” string in there at all. That’s at least what I would do

Thank, but what’s a hex editor?

Originally posted by p9931734:
Thank, but what’s a hex editor?

Would you be able to do some research on your own before asking questions like this?

Sorry. I’m just shock at the moment i read about it. I’m sure to do it the next time

Did you use the WGL_ARB_pixel_format functions to request a pixel format supporting FSAA prior to attempting to fill the glSampleCoverage function pointer?

Not sure if the driver is allowed to report WGL_ARB_multisampling without having a current pixelformat that it can be enabled on, BUT I thought it would be a good question to ask.

Have fun,
– Jeff

For me the function pointer get´s filled, even if I don´t have got a Pixelformat active, that supports AA.


i did. glSampleCoverageARB are called after the pixel formatting.

Anyway i tried to use a hex editor and realize that there isn’t a glSampleCoverageARB function within the driver.(I did manage to find other extensions)

So what’s the problem??? since the return string of wglGetExtensionString did return "WGL_ARB_multisampling "

I suppose you should try to update your drivers.